Search Engine

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
14,499
Reaction score
1,064
Points
113
Location
MA
Your Mac's Specs
2022 Mac Studio, macOS Monterrey, 32 GB
In what browser? Where does Yahoo appear?
 

pigoo3

Well-known member
Staff member
Admin
Joined
May 20, 2008
Messages
43,554
Reaction score
1,071
Points
113
Location
U.S.
Your Mac's Specs
2011 17" MBP 2.2ghz, 16gig ram, OS 10.11.6
Default search Engine: Google. Yet Yahoo appears.

Are you saying in Safari Preferences you have "Google" selected? If so…maybe you need to empty the Safari cache.

- Nick
 

vansmith

Senior Member
Joined
Oct 19, 2008
Messages
19,924
Reaction score
558
Points
113
Location
Queensland
Your Mac's Specs
Mini (2014, 2018, 2020), MBA (2020), iPad Pro (2018), iPhone 13 Pro Max, Watch (S6)
You need to provide details; please see the link in my signature for some ideas.
 
M

MacInWin

Guest
And check your extensions in Safari to see if Yahoo got installed there. If you installed anything from Cnet or Softonic, they may have hijacked your search engine with the Yahoo crapware.
 
OP
R
Joined
Sep 3, 2012
Messages
14
Reaction score
0
Points
1
I have Safari 7.1.2. It has no cache listed.
I recently installed Firefox and that's when my search default problem began.
(Engine Default : Google but Yahoo appears instead.)
I uninstalled Firefox and deleted its folder.
After restart , Yahoo pops up again as search.
I appreciate any suggestions.
Thank you- Rowena
 
Joined
Oct 16, 2010
Messages
15,564
Reaction score
723
Points
113
Location
Brentwood Bay, BC, Canada
In your Safari, try clicking the magnifying glass in the address bar and select Yahoo or Bing, and then select Google and see if it sticks.

You may want to try doing the selection and then restarting Safari and make or change the search option again.
 
OP
R
Joined
Sep 3, 2012
Messages
14
Reaction score
0
Points
1
I tried both suggestions. Sorry to say, neither work.
Thank you.-Rowena
 
M

MacInWin

Guest
Did you check extensions in Safari as I suggested? That's where a toolbar for Yahoo gets installed and that toolbar hijacks your search engine.
 
OP
R
Joined
Sep 3, 2012
Messages
14
Reaction score
0
Points
1
Jake, In the toolbar faded type says "google search" when entered Yahoo comes up.
In preferences, I changed to Bing. Again in toolbar says "bing search", entered again Yahoo.
Thank you-Rowena
 
M

MacInWin

Guest
Rowena, open Safari, on the top bar click on "Safari" then "Preferences" then "Extensions" and look for Yahoo there. That's what I was referring to. Yahoo can be installed there and hijack anything you set anywhere else.
 
OP
R
Joined
Sep 3, 2012
Messages
14
Reaction score
0
Points
1
Jake, my OS is Maverick. In Safari's preferences, Extensions sends me to apple.com extensions giving possible extensions rather than existing ones. Where else could I look?-Rowena
 
M

MacInWin

Guest
Are you sure you followed the steps? Safari didn't change that. Click on the Safari on the top bar, then Preferences and in the Preferences window Extensions. If you click on Extensions in the first drop down window, you get taken to Apple as you described. But you want Preferences.
 
OP
R
Joined
Sep 3, 2012
Messages
14
Reaction score
0
Points
1
Jake, Finally I found Extensions! (Thank you for being so ,so patient with me.)
In Extensions, I see "Extensions are created by third-party developers to customize and enhance your web experience." Then an ICON for searchtab 1.0 by Roby Strand (new tab extension ) with checked box "Enable seachtab" plus as "UNINSTALL" button. That's no mention of Yahoo or anything else.-Rowena
 

vansmith

Senior Member
Joined
Oct 19, 2008
Messages
19,924
Reaction score
558
Points
113
Location
Queensland
Your Mac's Specs
Mini (2014, 2018, 2020), MBA (2020), iPad Pro (2018), iPhone 13 Pro Max, Watch (S6)
Remove the SearchTab extension - my money's on this being the root cause of your issue.
 
Joined
Oct 16, 2010
Messages
15,564
Reaction score
723
Points
113
Location
Brentwood Bay, BC, Canada
Or maybe just try turning your Safari Extensions Off for a bit and see if things don't improve. I'm not sure if Safari has to be re-started or not when you do.

The option is in the On - Off switch:

Screen Shot 2015-01-23 at 9.29.26 AM.png
 
OP
R
Joined
Sep 3, 2012
Messages
14
Reaction score
0
Points
1
BINGO, Jake!
I uninstalled it, quit Safari, and did a restart: Safari opened with Google as directed in search engine.
It's not cocktail time here yet, but late the first toast goes to JAKE! Enjoy your day! Thank you, thank you thank you!!!-Rowena
Also thanks to other forum members who helped. You are appreciated.-R
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top