[OS X Mavericks] Enable Automatic Login

Joined
Nov 10, 2013
Messages
40
Reaction score
0
Points
6
How would I enable automatic login when the option is grayed out (even after authenticating) in login options, and there's no option (even after authenticating) in security and privacy? Thanks.
 
Joined
Oct 16, 2010
Messages
17,625
Reaction score
1,628
Points
113
Location
Brentwood Bay, BC, Canada
Your Mac's Specs
2011 27" iMac, 1TB(partitioned) SSD, 20GB, OS X 10.11.6 El Capitan
Try some basic maintenance:
Shutdown, wait a minute and then startup and boot up using Safe Boot Mode. Press and hold the shift key only when you hear the boot chime.

You can let go the shift key when you see the spinning gear, and when presented with the user to choose, type in the login password.

Then open and run Disk Utility and Repair Permissions and Verify Disk on the boot volume.

When it's all finished and hopefully all passed OK, just restart normally and try again to set your login options using your admin user account.
 

Slydude

Well-known member
Staff member
Moderator
Joined
Nov 15, 2009
Messages
17,661
Reaction score
1,113
Points
113
Location
North Louisiana, USA
Your Mac's Specs
M1 MacMini 16 GB - Ventura, iPhone 14 Pro Max, 2015 iMac 16 GB Monterey
Are you using an administrator account or a standard account?
 
OP
A
Joined
Nov 10, 2013
Messages
40
Reaction score
0
Points
6
Try some basic maintenance:
Shutdown, wait a minute and then startup and boot up using Safe Boot Mode. Press and hold the shift key only when you hear the boot chime.

You can let go the shift key when you see the spinning gear, and when presented with the user to choose, type in the login password.

Then open and run Disk Utility and Repair Permissions and Verify Disk on the boot volume.

When it's all finished and hopefully all passed OK, just restart normally and try again to set your login options using your admin user account.

Thanks, I'll try that.

UPDATE: I booted into Safe Mode, Verified/Repaired the Disk, and Verified/Repaired the Disk Permissions. Upon reboot, the issue still persists.
 
Last edited:
Joined
Apr 26, 2008
Messages
2,963
Reaction score
120
Points
63
Location
Belgium
Your Mac's Specs
iPad Pro 12.9 latest iOS
Let's try the simple route.
When you are in system preferences / users and groups / login items you will see a padlock in the bottom left hand corner.
Is that padlock closed or open ?
If it is closed, you can not make changes. Click on it and type the admin password. Now you can change system preferences.

Cheers ... McBie
 
OP
A
Joined
Nov 10, 2013
Messages
40
Reaction score
0
Points
6
Let's try the simple route.
When you are in system preferences / users and groups / login items you will see a padlock in the bottom left hand corner.
Is that padlock closed or open ?
If it is closed, you can not make changes. Click on it and type the admin password. Now you can change system preferences.

Cheers ... McBie

As I said in the original post, I have authenticated with the administrator password and enabling automatic login is still out of the question: Screen Shot 2014-09-26 at 9.38.57 AM.png
 
Joined
Apr 26, 2008
Messages
2,963
Reaction score
120
Points
63
Location
Belgium
Your Mac's Specs
iPad Pro 12.9 latest iOS
Thanks for that clarifications and the print screen.
I read your original post where you said you " authenticated " .... in the OS X environment you can authenticate at different stages for different purposes. That was not clear.

I will try to simulate what you are experiencing and get back to you.
First thing I can think of is Preferences/Security&Privacy/General .... is the box next to " Disable Automatic Login " checked or un-checked ?


Cheers ... McBie
 
OP
A
Joined
Nov 10, 2013
Messages
40
Reaction score
0
Points
6
Thanks for that clarifications and the print screen.
I read your original post where you said you " authenticated " .... in the OS X environment you can authenticate at different stages for different purposes. That was not clear.

I will try to simulate what you are experiencing and get back to you.
First thing I can think of is Preferences/Security&Privacy/General .... is the box next to " Disable Automatic Login " checked or un-checked ?


Cheers ... McBie

I don't see "Disable Automatic Login."

Screen Shot 2014-09-26 at 10.00.33 AM.png "
 
Joined
Aug 5, 2008
Messages
345
Reaction score
14
Points
18
Location
Central New York
Can't have automatic login when FileVault is enabled ... part of securing your data, I guess.
 
Joined
Apr 26, 2008
Messages
2,963
Reaction score
120
Points
63
Location
Belgium
Your Mac's Specs
iPad Pro 12.9 latest iOS
Can't have automatic login when FileVault is enabled ... part of securing your data, I guess.

To me, that would make sense. ( In terms of data protection )
Is there a way to confirm this ?


@Applegeek ..... what version of the OS are you running ?


Cheers ... McBie
 
Joined
Oct 16, 2010
Messages
17,625
Reaction score
1,628
Points
113
Location
Brentwood Bay, BC, Canada
Your Mac's Specs
2011 27" iMac, 1TB(partitioned) SSD, 20GB, OS X 10.11.6 El Capitan
Joined
Aug 5, 2008
Messages
345
Reaction score
14
Points
18
Location
Central New York
No problem according to Apple, to be able to have automatic login enabled or disabled when FileVault is enabled.

Good find!

I wonder if that's a part of Onyx (should be if not).
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top