Xcode stopped letting me run Xcode app on iPad

Aug 23, 2011
Reaction score
I recently corrupted my iPads native video app and had to do a restore. Everything was successfully restored except that now it appears that Xcode doesn't like my iOS version anymore. I have the latest software updates and Xcode organiser window even shows the same version in the Installed version as what it wants me to restore to, i.e. 5.0 (9A334). Bizaar. I've tried restoring my iPad but get the same issue over and over. (see attached). The message is:

The version of iOS on “Iva's iPad” doesn't match any of the versions of iOS supported for development with this installation of the iOS SDK.

I've also tried clicking "add to portal" which doesn't make any differenceSee attached

Has anyone had similar experience and could advise how i can fix this?

Thank you

Organiser Devices Message.jpg

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.