Why my name in Finder bar is touching the top?

Joined
Dec 3, 2011
Messages
8
Reaction score
0
Points
1
Screen+Shot+2011-09-20+at+6.49.13+PM.png


As shown in image above, my name is touching the top whether it should be having the same space from top and bottom.

I tried posting the same question on Apple Support but no one replied, do someone have a solution for the same?
 
Joined
Sep 30, 2007
Messages
9,962
Reaction score
1,236
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
Open up System Preferences and go to Users & Groups. Select Login Options, click the lock to authorize if need be, then try turning off the option to show the faster user switching menu, then on. If that doesn't work, try the other choices (short name and icon) to see what happens.

If that doesn't work, we'll have to try deleting a preference file and let OS X rebuild it. I'm not sure offhand which one yet, so try the above first.
 
OP
M
Joined
Dec 3, 2011
Messages
8
Reaction score
0
Points
1
I followed the steps as you said, for icon its ok but when I select full name or short name, it goes wrong again.

Let's try deleting the preference file, you are saying. Thanks in advance!
 
Joined
Jul 30, 2009
Messages
7,306
Reaction score
310
Points
83
Location
Wisconsin
Your Mac's Specs
Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
If that doesn't work, we'll have to try deleting a preference file and let OS X rebuild it. I'm not sure offhand which one yet, so try the above first.

I think that would be com.apple.systemuiserver.plist

the User Interface contains menu bar settings
 
Joined
Sep 30, 2007
Messages
9,962
Reaction score
1,236
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
I followed the steps as you said, for icon its ok but when I select full name or short name, it goes wrong again.

Let's try deleting the preference file, you are saying. Thanks in advance!

Alrighty. Well it's probably the same plist as this one just used in another tip involving the menubar (hat tip to toMACsh). Go to:

yourhomefolder/Library/Preferences/com.apple.systemuiserver.plist

Drag it to your Desktop. Then log out and back in. If that fixes it, delete the original you put on the Desktop. If not, feel free to move it back and we'll try a different one.
 
OP
M
Joined
Dec 3, 2011
Messages
8
Reaction score
0
Points
1
@ lifeisabeach,
Sorry I checked for it again and again but couldn't find the same, may be that's this problem is with me.

I tried searching for it multiple times but I can't find it anywhere, what's next?
 
Joined
Jul 30, 2009
Messages
7,306
Reaction score
310
Points
83
Location
Wisconsin
Your Mac's Specs
Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
What OS do you have? In the path above "yourhomefolder" is whatever you named it. Usually, that folder's icon is a little white house. There are two other Library folders. You have to be in the right one. In Lion, the folder is hidden. Since I don't have Lion, I can't remember how to find it, though I've seen that trick explained before.
 
Joined
Sep 30, 2007
Messages
9,962
Reaction score
1,236
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
Just to make it simple, download EasyFind and do a search of your home folder (select from the drop down menu on the right) for the file com.apple.systemuiserver.plist. You can delete it from there.
 
OP
M
Joined
Dec 3, 2011
Messages
8
Reaction score
0
Points
1
@ lifeisabeach, it was a nice software, the folder was hidden, but deleting that file doesn't fixes anything, after deleting the file and logging out again, I tried turned on Fast user switching menu and it shows as earlier. That's not working at all.

Also I lost of my icons in finder bar, but restoring the deleted file in preference brings all icons back.

@toMACsh, yes you were right, the folder was hidden, EasyFind was quick enough to find it, but unfortunately deleting that file couldn't solve the problem.
 
Joined
Jul 30, 2009
Messages
7,306
Reaction score
310
Points
83
Location
Wisconsin
Your Mac's Specs
Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
@toMACsh, yes you were right, the folder was hidden, EasyFind was quick enough to find it, but unfortunately deleting that file couldn't solve the problem.

No, if that file being corrupt is the problem, just deleting it would not solve it. You also have to restart the computer for the OS to make a new default plist file.
 
OP
M
Joined
Dec 3, 2011
Messages
8
Reaction score
0
Points
1
No, if that file being corrupt is the problem, just deleting it would not solve it. You also have to restart the computer for the OS to make a new default plist file.

I used to logout and then log in again.

I just tried it by restating that also doesn't works.
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,247
Reaction score
1,834
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
As long as you have the "Show fast user switching menu" item checked off in System Preferences, Users & Groups, and the full name item is selected, that will always appear in the top menu. Deleting the plist will not remove it.

Instead of selecting show "full name", use the drop down menu and change it to "icon" instead.

Or, just turn off "Show fast user switching" altogether. Note that you have to click on the small lock at the bottom and put in your admin password to make changes.
 
OP
M
Joined
Dec 3, 2011
Messages
8
Reaction score
0
Points
1
As long as you have the "Show fast user switching menu" item checked off in System Preferences, Users & Groups, and the full name item is selected, that will always appear in the top menu. Deleting the plist will not remove it.

Instead of selecting show "full name", use the drop down menu and change it to "icon" instead.

Or, just turn off "Show fast user switching" altogether. Note that you have to click on the small lock at the bottom and put in your admin password to make changes.

Thanks for the reply, icon is showing correctly since the start but the problem is with short name and full name. I want them to show correctly.
 
Joined
Sep 30, 2007
Messages
9,962
Reaction score
1,236
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
@ lifeisabeach, it was a nice software, the folder was hidden, but deleting that file doesn't fixes anything, after deleting the file and logging out again, I tried turned on Fast user switching menu and it shows as earlier. That's not working at all.

Also I lost of my icons in finder bar, but restoring the deleted file in preference brings all icons back.

Yes, that file does store a lot of preferences, so deleting would have affected more than simply the user switching menu. But letting OS X re-create a default one obviously didn't fix it, so that particular file isn't the right one.

I have an idea. I'm wondering if you are using the wrong font, or if the font is corrupt. First download and run TinkerTool. If your fonts don't match my screenshot, reset them to the defaults and reboot.

Fonts.jpg

If they do match, then open Font Book, select the Lucida Grande font, then go to the menu and select File » Validate Font.
 
OP
M
Joined
Dec 3, 2011
Messages
8
Reaction score
0
Points
1
Yes, that file does store a lot of preferences, so deleting would have affected more than simply the user switching menu. But letting OS X re-create a default one obviously didn't fix it, so that particular file isn't the right one.

I have an idea. I'm wondering if you are using the wrong font, or if the font is corrupt. First download and run TinkerTool. If your fonts don't match my screenshot, reset them to the defaults and reboot.

View attachment 16378

If they do match, then open Font Book, select the Lucida Grande font, then go to the menu and select File » Validate Font.

That's it. Results were matching, but there were multiple copies installed of Lucida Grande, so I clicked on Resolve automatically and then logged out and logged in again. And now it shows fine.

Thank you so much for helping me out so faster, you guys are great.

Screen Shot 2011-12-04 at 10.35.49 PM.png
 
Joined
Jul 30, 2009
Messages
7,306
Reaction score
310
Points
83
Location
Wisconsin
Your Mac's Specs
Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
As long as you have the "Show fast user switching menu" item checked off in System Preferences, Users & Groups, and the full name item is selected, that will always appear in the top menu.

Not that it's relevant to the OP's problem now that it's resolved, but, what OS? I still have Leopard, and there is no Users & Groups in SP. (Btw, OP did not specify which OS version...)
 
Joined
Sep 30, 2007
Messages
9,962
Reaction score
1,236
Points
113
Location
The Republic of Neptune
Your Mac's Specs
2019 iMac 27"; 2020 M1 MacBook Air; macOS up-to-date... always.
Not that it's relevant to the OP's problem now that it's resolved, but, what OS? I still have Leopard, and there is no Users & Groups in SP. (Btw, OP did not specify which OS version...)

It's the preference pane formerly named "Accounts" prior to Lion.
 
Joined
Jul 30, 2009
Messages
7,306
Reaction score
310
Points
83
Location
Wisconsin
Your Mac's Specs
Mac Mini (Late 2014) 2.6GHz Intel Core i5 Memory: 8GB 1600MHz DDR3
Ah, good to know.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top