Reverted back to Mavericks, can't use some apps now

Joined
Sep 26, 2011
Messages
8
Reaction score
0
Points
1
I started having GPU problems when I updated to Yosemite on my early 2011 15" Macbook Pro in November. When I updated to the most recent version last week, my Macbook bricked on me. The computer repair guy was able to get my computer to work with Mavericks, but now I can't use many of my apps. I had a back up copy of the apps, but many of them were updated since November. I get the following message: "You have OS*X 10.9.5. The application requires OS*X 10.10 or later"
Is there any way of getting older versions of the apps that would work with Mavericks?
Thanks
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,249
Reaction score
1,830
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
You may be able to get hold of older versions that will work with Mavericks but that's up to you to find out by going to the developer's site and check. It would be much easier if you just reinstalled Yosemite. There's no reason why a 2011 15" MacBook Pro can't run Yosemite better than Mavericks.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top