Really crazy issue: any external hard drive will not show up on desktop !

Feb 11, 2015
Reaction score
Hello all,

I am hit by a pretty bad issue here I need help with.

I've discovered yesterday that when I connect an external hard drive to my computer (Macbook Pro model 5.1, OS 10.8.5) in USB or Firewire, the hard drives do not mount in the finder/desktop. I tried with 4 different hard drives, all previously formatted for Mac OS Extended Journaled, all Western Digital and the issue persists with each one of them. I tried using 2 different USB cables for the US hard drives and the issue persists. The drives I tried with are my hard drives that I have used many times, some for a few years already, with the same computer with no issues at all in the past. I believe the issue is on the computer side either software/OS or possibly hardware related.

Below is some more info. I do know my writing is very long but there is a lot of background, testing involved and useful info I'm putting down here to help identify this very wired issue.

Last week my computer did not boot up. It was stuck on the Apple logo/grey screen and loading wheel for infinity. At first I thought it was the RAM so I did some test, taking one bar of RAM out, then the other, booting up but the issue persisted. Then by trying to boot from the recovery partition which did not show up, I concluded, the issue was the internal hard drive. I replaced it with a new one and same model, reinstalled and restored my system from a Timemachine back up. So far, 5 days after, there has been no issues I noticed except this issue I'm having now with hard drives just not showing up.

I did a few tests:
If I open disk utility with one of the drive connected (I chose here a Back up of my system done with Carbon Copy Cloner), it shows like this

As you can see the drive, appears fine in disc utility but the 1 named partition (here BACK UP SYSREM 1) is greyed out. I however can select it. If I performed a verify disc, the operation goes ahead and disc utility reports "the volume BACK UP SYSTEM 1 appears to be OK".

Here is where it gets interesting:
Because I have 2 bootable backups hard drives of my computer + 1 Timemachine back hard drive, I decided to erase and reformat this BACK UP SYSTEM 1 hard drive in disc utility. When the operation is done, the hard drives does appear on the desktop FINE !

BUT, as soon as I eject the drive, disconnect the USB cable and then reconnect, the drive DOES NOT show up on in the finder / desktop and the issue is the same.

Last wired thing is: I keep my old internal hard drive that I replaced in my computer. I have a doc for hard drives that I use very often to work with internal hard drives, externally. So I connected my old internal drive on the dock and the drive appears fine in disc utility and it does not show up on the desktop like the other ones. So something leads me to believe that the computer (maybe the OS) is acting wired with hard drives whatever the type of connection, USB, Firewire or SATA internally.

I have been working in video production and editing for many years, involved with many different computers and hard drives. I've seen many glitches and drives issue, failures, corrupted drives, OSX issues over the years but this I never saw.

Thank you !

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.