newbie help (dumb terminal settings?)

C

CaptainMack

Guest
i am new to this (as in started yesterday) and whenever i start up it says i am using dumb terminal settings. can i change this because i think it prevents me from doing stuff.
here is exactly what it says in case you need it:

Last login: Thu Jan 15 14:10:25 on ttyp1
Welcome to Darwin!
tcsh: Cannot open /etc/termcap.
tcsh: using dumb terminal settings.
 

rman


Retired Staff
Joined
Dec 24, 2002
Messages
12,626
Reaction score
168
Points
63
Location
Los Angeles, California
Your Mac's Specs
14in MacBook Pro M1 Max 32GB 2TB
Not knowing what you may have done. Did you make any change to tcsh shell environment?

There is normally a dot file that control or defines your environment. An example woulod be in csh (c-shell) the .cshrc file, in sh (borne shell) and ksh (korn shell) there is the .profile. I currently don't know what tcsh (trusted shell) uses.
 

rman


Retired Staff
Joined
Dec 24, 2002
Messages
12,626
Reaction score
168
Points
63
Location
Los Angeles, California
Your Mac's Specs
14in MacBook Pro M1 Max 32GB 2TB
I have found the dot file for tcsh (.tcshrc).

Since you have not changed anything. Have you deleted anything?
 
OP
C

CaptainMack

Guest
no i havent deleted anything i look on the web and people said to make sure i hade the vt100 file in /usr/share/terminfo/76/ i do. i also realised that when i open a new shell i am not using dumb terminal settings. i am only using them when i login to a new naame and log back into my name.
 
OP
M

masaka___

Guest
Let's look at the error message again. It says it can't open /etc/termcap, so look to see if it's there. Tell us what happens when you type:

ls -l /etc/termcap

If the file isn't there, you should find a suitable termcap file, and put it in /etc. I've attached one from a Redhat box that you should be able to use, because termcap files don't vary much (if at all) between operating systems. Or at least that's my understanding. Just get rid of the .txt extension in the attachment and copy it to /etc, but that's only if there isn't a termcap file there already.

View attachment termcap.txt
 
OP
C

CaptainMack

Guest
it says no such file so i guess that means none is there.
how exactly do i copy the termcap file to /etc
(pardon my ignorence but i am new to all this:p)
 
OP
M

masaka___

Guest
CaptainMack said:
it says no such file so i guess that means none is there.
how exactly do i copy the termcap file to /etc
(pardon my ignorence but i am new to all this:p)

It's cool...

Let's suppose you saved "termcap.txt" to your Desktop. Here's how
you'd copy it to the right place.

sudo cp ~/Desktop/termcap.txt /etc/termcap


Explanation:

sudo is a command you use when you want to
temporarily upgrade your normal account to have
administrator (root) priveleges. Copying things
into /etc (which is where a lot of Unix programs
like to place their configuration files) is an
appropriate time to use sudo. When you execute
sudo, it'll usually ask you for your password
(so it can make sure you're not someone
malicious).

cp is Unix command to copy files, and it's
syntax is `cp SOURCE DESTINATION`. You can
specify multiple sources, but there must always
only be one destination. The destination will
usually be a directory (or folder), but if you
specify a filename (as we've done here), it'll
perform a rename operation after the copy.


Summary:

sudo cp ~/Desktop/termcap.txt /etc/termcap

sudo -- temporarily give me more priveleges so that I can...

cp -- copy ~/Desktop/termcap.txt to /etc and have it be named termcap


PS: ~ means your home directory. You can say `echo ~` and it should say /Users/whomever where "whomever" is your login name.

PPS: to learn more about sudo and cp, type `man sudo` and `man cp` in your terminal.
 
OP
C

CaptainMack

Guest
i did all that and it still says this.

Last login: Tue Feb 17 15:06:41 on ttyp2
Welcome to Darwin!
tcsh: No entry for terminal type "network"
tcsh: using dumb terminal settings.
 
OP
M

masaka___

Guest
CaptainMack said:
no i havent deleted anything i look on the web and people said to make sure i hade the vt100 file in /usr/share/terminfo/76/ i do. i also realised that when i open a new shell i am not using dumb terminal settings. i am only using them when i login to a new naame and log back into my name.

I totally missed this post, but it explains a lot. Let me guess -- you're typing "login" at the shell prompt, and logging in as someone else. If that's the case, let me show you a better way to log in as someone else.

su - username

...where username is the name of the person you want to log in as. FYI, login is not a program that you normally execute from the shell. Instead, it's usually started by a program called getty, but that's another story.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top