need docx to open in word and not vmware

Joined
Apr 5, 2010
Messages
2
Reaction score
0
Points
1
Hi all! Im new here and this is my first post. :)

A quick rundown of my issue- i used to have vmware installed and i uninstalled it and now my .docx files are trying to open from word in vmware which wont work. how can i have it open with word from within OS X? btw excel doesnt have this problem. thanks for any help!!
 

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
15,817
Reaction score
2,172
Points
113
Location
MA
Your Mac's Specs
2022 Mac Studio M1 Max, 2023 M2 MBA
What happen is you choose the file, then Get Info and default it to use Word?

Regards
 
Joined
Dec 13, 2007
Messages
125
Reaction score
1
Points
18
Location
Taipei
Your Mac's Specs
Macbook Pro 15" (early 2008, pre-unibody), 2.4GHz Core 2 Duo, 4GB RAM.
This can be done by right clicking (ctr. click) on a .docx file, selecting 'open with other program', selecting 'other' from the list, then selecting 'Microsoft Word.app' from you mac application file, and finially marking the check box that says 'open with this program every time.'

That said, this can also be done from system preferences > other > default applications >. Select the 'extensions' tab. Select '.docx' from the list. Then select Microsoft Word.app from the jump menu. Do the same for '.doc' files. This second solution is a good one to know for similar application association problems in the future.
 
Joined
Apr 7, 2009
Messages
3,308
Reaction score
58
Points
48
Location
Whangarei NZ
Your Mac's Specs
27 iMac+Thunderbolt, iMac 21,
this can also be done from system preferences > other > default applications >. Select the 'extensions' tab.
Not following here - looked in my System Preferences and there is no Other. Do u mean sys prefs or an Apps Preferences?
 
Joined
Dec 13, 2007
Messages
125
Reaction score
1
Points
18
Location
Taipei
Your Mac's Specs
Macbook Pro 15" (early 2008, pre-unibody), 2.4GHz Core 2 Duo, 4GB RAM.
OP
H
Joined
Apr 5, 2010
Messages
2
Reaction score
0
Points
1
This can be done by right clicking (ctr. click) on a .docx file, selecting 'open with other program', selecting 'other' from the list, then selecting 'Microsoft Word.app' from you mac application file, and finially marking the check box that says 'open with this program every time.'

That said, this can also be done from system preferences > other > default applications >. Select the 'extensions' tab. Select '.docx' from the list. Then select Microsoft Word.app from the jump menu. Do the same for '.doc' files. This second solution is a good one to know for similar application association problems in the future.

You guys were all great!! Thank you so much for all the help!
even though there was no default applications under system preferences but being in IT i digged around and figured out how to do it from the applications page. thanks again!:)
 
Joined
Dec 13, 2007
Messages
125
Reaction score
1
Points
18
Location
Taipei
Your Mac's Specs
Macbook Pro 15" (early 2008, pre-unibody), 2.4GHz Core 2 Duo, 4GB RAM.
My bad, I've installed so many thrid party preference pane add-ins, I forgot this 'default applications' pane was one of them! It's actually Rubicode's RCDefaultApp. It's freeware, and it got five starts from a Macworld review.

Also, there's a description of just the probroblem you were having, heythug015, here, along with another plug for RCDefaultApp. (though it is a bit old, 2007, don't know if there's an even better solution out there now)
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top