Mounting Iso in Windows 8.1 in Parallels Issue

Apr 9, 2015
Reaction score
I managed to get parallels installed and I'm running windows 8.1. I'm having issues installing applications with iso files. I tried using windows mounting and it kicks an error. I realized I could open the .iso file in Mac OS and that mounts the iso. So I go back into windows click on the mounted drive and try to run auto run, setup, installer, or whatever I need depending on the application and I am getting a different error for each application. I even tried installing daemon tools on both Mac os and Windows os to mount different iso files and it still doesn't work.

Does anyone have any ideas or can someone point me in the right direction? I'm new to mac (windows user) and I'm at a dead end with this...


Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.