macbook not keeping wireless connection

Joined
Jan 11, 2012
Messages
47
Reaction score
0
Points
6
Usually my macbook would always connect to the last wireless network I was on whenever I startup or just lift the monitor up. Of course the network changes if I go to a different house or hotel, etc.

But now I constantly have to pick the network to connect to over and over again every time I startup from sleep mode and such. I even deleted the networks I no longer use, but that didn't help.

Why would I have to keep choosing the network every time?
 

cwa107


Retired Staff
Joined
Dec 20, 2006
Messages
27,038
Reaction score
810
Points
113
Location
Lake Mary, Florida
Your Mac's Specs
14" MacBook Pro M1 Pro, 16GB RAM, 1TB SSD
Did you upgrade to Yosemite recently? This and other WiFi issues have plagued Yosemite since its release. Apple was supposed to have sorted them in 10.10.1, but there's still quite a bit of kerfuffle on the interwebs about it.

Hopefully that's not your issue, but could you clarify exactly which MacBook model you have an what version of OS X it's running?
 
Joined
Jan 11, 2012
Messages
47
Reaction score
0
Points
6
Did you upgrade to Yosemite recently? This and other WiFi issues have plagued Yosemite since its release. Apple was supposed to have sorted them in 10.10.1, but there's still quite a bit of kerfuffle on the interwebs about it.

Hopefully that's not your issue, but could you clarify exactly which MacBook model you have an what version of OS X it's running?

No I did not upgrade to Yosemite yet.

I'll post the comp specs later, I'm not home now.
This happened suddenly also, not after an update or anything. Last night I installed a few updates, but the problem was still there this morning. :Grimmace:
 
Joined
Mar 17, 2009
Messages
3,626
Reaction score
111
Points
63
Your Mac's Specs
2018 15" MBP, 2019 11" iPad Pro, iPhone 11 Pro
I know you said you deleted the networks that you don't use, but have you tried deleting ALL networks? Clearing the list completely might help. just a suggestion...
 
Joined
Jan 11, 2012
Messages
47
Reaction score
0
Points
6
I know you said you deleted the networks that you don't use, but have you tried deleting ALL networks? Clearing the list completely might help. just a suggestion...

I'll try that.

Here are specs:
Model Name: MacBook Pro
Model Identifier: MacBookPro9,2
Processor Name: Intel Core i5
Processor Speed: 2.5 GHz
Number of Processors: 1
Total Number of Cores: 2
L2 Cache (per Core): 256 KB
L3 Cache: 3 MB
Memory: 8 GB

Am I missing anything?

Also, when I switch users I need to manually connecting the wireless network, even though I was already connected to it before I switched the user.
:Confused:
 

cwa107


Retired Staff
Joined
Dec 20, 2006
Messages
27,038
Reaction score
810
Points
113
Location
Lake Mary, Florida
Your Mac's Specs
14" MacBook Pro M1 Pro, 16GB RAM, 1TB SSD
Thank you, that helps.

In addition to deleting and readding all networks, I'd recommend a PRAM reset. Here's how to do it....

1. Turn off the Mac completely.
2. Turn it on and immediately press (and hold) Command + Option + P + R.
3. Continue holding until you hear the system chime 3 times.
4. Release and the machine should boot normally.

Hope that helps.
 
Joined
Jan 11, 2012
Messages
47
Reaction score
0
Points
6
Thank you, that helps.

In addition to deleting and readding all networks, I'd recommend a PRAM reset. Here's how to do it....

1. Turn off the Mac completely.
2. Turn it on and immediately press (and hold) Command + Option + P + R.
3. Continue holding until you hear the system chime 3 times.
4. Release and the machine should boot normally.

Hope that helps.

Been busy, haven't tried that PRM reset yet, but another thing I noticed is
-if I have 2 users logged on and both connected to wireless.
-when I log off of 1 user, I have to re-select the wireless network on the other.

does that seem like a PRAM issue?
 
Joined
Feb 7, 2004
Messages
385
Reaction score
1
Points
18
Location
The land of paella.
Your Mac's Specs
Norwood is a Mid-2010 15 inch MacBook Pro with 10.11.1.
My MacBook Pro kept doing that too, and until about 3 days ago I thought it was Mavericks. Turned out the walls in my bedroom are thicker than I expected. I found this out when I opened my laptop from sleep mode in another room in my flat and it connected instantly.

I've also noticed that if I have my bedroom door slightly ajar it improves my chances of being able to pick up the wi-fi signal.
 
Joined
Jan 11, 2012
Messages
47
Reaction score
0
Points
6
My MacBook Pro kept doing that too, and until about 3 days ago I thought it was Mavericks. Turned out the walls in my bedroom are thicker than I expected. I found this out when I opened my laptop from sleep mode in another room in my flat and it connected instantly.

I've also noticed that if I have my bedroom door slightly ajar it improves my chances of being able to pick up the wi-fi signal.

I don't think distance is the problem. I'm picking up my neighbors network from across the street as well as tons of others around me.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top