Mac OSX/Tomcat issue

Apr 13, 2010
Reaction score
I am new to Mac OSX. I have created a web service that makes a call to an external application. The problem is, the parameters are not being passed to the external application when I am logged in as myself. If I log in as root, the parameters are passed to the application without issue. If I run the Java class directly from the IDE (not as a web service) the parameters are passed correctly.

I ran into another issue where I could not create log files from log4j. After (accidentally) stumbling upon the catalina.policy file I made an entry which allowed the log files to be created on the syste (when logged in as myself).

I am wondering if there is an entry that is required in the policy file to allow me to pass parameters to an external application call made from a web service, on Mac OSX.

FYI, when the same code is run on a PC it works without issue. As the Mac is Unix based, and since it works when logged in as root, I am assuming that this is a privileges/permission issue. I just do not know what/where to update to get this running.

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.