jumping generic icons



I upgraded to 10.2.8 and have a BIG problem.
Suddenly original icons changed to generic, like installer, directory access, image capture and a few other Apple programs/utilities.
when i click any, the generic icon appears in the dock, jumps a few times, then disappears and nothing happens.
I used DuskUtility to do its thing, and it repaired a few flaws.
But the problem didn't go away.
When I try to reinstall the 10.2.8 combo, the same thing happens with the jumping/disappearing INSTALLER icon..
Actually, ALL new installations that need to make use of the INSTALLER encounter the same problem.
I tried to reinstall OS X from the original cd-roms, but it freeze: the screen shows the apple logo on blue background, and in the middle of the screen a white bar with lots of "snow" (like a bad reception on a TV).

I can use my Mac fine: no problems being online, using Word or any other program, only I can't install anything.
Please let me know what the problem is and how to solve.


Same Problem, kinda

Well, I installed the same update (10.2.8) and this is what happened.

My Itunes and Quicktime icons in the dock turned to folders.
I could not drag and drop anything.

So I ran a program called Dragster that says it may fix this exact problem. No Luck.

Instead, now all my icons everywhere are either folders or some other little pencil icon and it seems that file associations don't work anymore.

I'm looking everywhere for a solution, but no luck so far.

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.