IPod Touch 4th Gen Start Up Problems!

Sep 28, 2009
Reaction score
I Jailbroke my ipod touch 4th gen a while ago now (last year), I decided to update my ipod to IOS 5 recently but every time I would try, it would 'time out', so I decided to restore it, which I later found out to be a very bad idea due to it not fully powering on; the apple logo comes up which then turns into the green poison logo, after while it goes to a white screen and then does the same thing again? I've tried pressing the home button and the sleep button together which causes the screen to flash white and restart again, that doesn't do anything. My computer doesn't pick it up when I connect it to it until I switch it off, re-plug it to the computer and press the home button and the sleep button together at the same time, which then causes the ITunes logo to come up on the screen, this then causes my computer to detect that my IPod touch needs to be restored, it then starts downloading IOS 4 after a while it stops and times out, I've even tried on my sister's computer. Is there anything else that I could do? Do I need to open it up and do something with the inside? I'm not willing to pay 250 quid for another IPod and yes i've learnt my lesson, im never jailbreaking EVER again! Help? :'(

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.