iMac Newbie - can't boot to cd



Hello everyone,

I just got an iMac Rev A (233mhz) from a friend. The hard drive died, and they said I could just have it. I had some hard drives laying around, and threw a 6gb drive in there.

They haven't given me the OS or system CD's, so I downloaded a copy of Linux (Mandrake) that runs on Linux. I booted the CD, and installed Linux - no prob.

When the install completed, it said I should run the command "setenv boot-device hd:2,\\:tbxi" at the system prompt, which I did. This makes the iMac boot to the linux partition, but something went wrong, and Linux won't boot. Ok, so I just will boot from CD and try again, right?

But now I can't boot from the CD. It either tells me that the kernel is bad, or starts giving me "default catch" errors.

Can anyone help me to get the iMac booting from the CDROM again? I even tried removing the HD and putting a blank HD in. I tried two different known-good-bootable CD's (Mandrake and Yellow Dog Linux). I tried running "setenv boot-device cd:0". I tried holding down the C: key. I don't know what else to do?

Any help would be appreciated. Please contact me via email as well please.


Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.