iMac (airport) has hard time connecting to wireless

Joined
Nov 21, 2011
Messages
10
Reaction score
0
Points
1
I'm new to the Mac world and so far so good EXCEPT for the wireless connection issue. These are the messages I get when I try to connect to a wireless signal using airport:

"AirPort does not have an IP address and cannot connect to the Internet."

"AirPort has the self-assigned IP address xxxxxxxxxxxxx and will not be able to connect to the Internet."


It usually connects after a 15-20 minute wait or sometimes I can click on "Renew DHCP Lease" and that will work but not always.

Notes:
- I'm running Snow Leopard v10.6.8.
- I have no problem connecting w/ my ipad or pc

Any suggestions?
 
Joined
Sep 10, 2011
Messages
1,823
Reaction score
51
Points
48
Location
Lancashire
Your Mac's Specs
MacBook Air M1 2020 Ventura 13.4.1 500Gb 8Gb. iPhone12, Watch 5, HomePods.
Hi,
Have you used the diagnostics in Network Preferences at all ?
 
Joined
Sep 10, 2011
Messages
1,823
Reaction score
51
Points
48
Location
Lancashire
Your Mac's Specs
MacBook Air M1 2020 Ventura 13.4.1 500Gb 8Gb. iPhone12, Watch 5, HomePods.
The message seems very specific. When you booted up your iMac for the first time it should have asked you if you wanted to connect to the wireless connection it found. Unless you configured it later manually?

In System Preferences/Network/Wireless do you have Location 'Automatic checked and Wi-Fi turned on ?
 
OP
I
Joined
Nov 21, 2011
Messages
10
Reaction score
0
Points
1
In System Preferences/Network/Wireless do you have Location 'Automatic checked and Wi-Fi turned on ?

In System Preferences/Network, I do not see "Wireless" and only see "Airport", "Ethernet", and "Firewire".

This morning the airport had no issues connecting to the wireless. I'm wondering if it had anything to do w/ clicking "Turn AirPort Off" last night.

Also, I noticed when I restart the computer, it would connect with no issues. It's only when I put the imac to sleep w/o turning airport off that this issue seems to be happening.
 
Joined
Jan 19, 2008
Messages
4,695
Reaction score
73
Points
48
Location
houston texas
Your Mac's Specs
09 MBP 8GB ram 500GB HD OS 10.9 32B iPad 4 32GB iPhone 5 iOs7 2TB TC Apple TV3
System Preferences > Network >Left Column at the top should be Wi-Fi with a green dot
showing connected and on the left column status connected should show your network if not click on advanced Wi-Fi > Preferred network drag yours to the top and edit the rest if any others are listed.
 
OP
I
Joined
Nov 21, 2011
Messages
10
Reaction score
0
Points
1
System Preferences > Network >Left Column at the top should be Wi-Fi with a green dot
showing connected and on the left column status connected should show your network if not click on advanced Wi-Fi > Preferred network drag yours to the top and edit the rest if any others are listed.

hmm I don't see Wi-Fi anywhere, even when I click Advanced. I only see:
AirPort | TCP/IP | DNS | WINS | 802.1X | Proxies | Ethernet
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,247
Reaction score
1,834
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
hmm I don't see Wi-Fi anywhere, even when I click Advanced. I only see:
AirPort | TCP/IP | DNS | WINS | 802.1X | Proxies | Ethernet

Are you actually connected to WiFi when opening System Preferences, Network? If not, WiFi will not show up on the list. Make sure you're connected and locked on to the signal, then open System Preferences, Network, and do what member osxx said.
 
Joined
Nov 28, 2007
Messages
25,564
Reaction score
486
Points
83
Location
Blue Mountains NSW Australia
Your Mac's Specs
Silver M1 iMac 512/16/8/8 macOS 11.6
Did wifi only appear with Lion? From memory when running Snow Leopard did state Airport. Seeing Airport under Advanced confirms this. Location is Automatic and the network name appears in the window pane?

Have you tried re-setting the modem/router and if no joy follow the manual to go into the browser address and set up a new network. And when you go into Advanced > DNS do two sets of IP addresses appear there? If not ask your ISP for the addresses. One is primary and the second one, secondary of course.
 
Joined
Sep 10, 2011
Messages
1,823
Reaction score
51
Points
48
Location
Lancashire
Your Mac's Specs
MacBook Air M1 2020 Ventura 13.4.1 500Gb 8Gb. iPhone12, Watch 5, HomePods.
Are you actually connected to WiFi when opening System Preferences, Network? If not, WiFi will not show up on the list. Make sure you're connected and locked on to the signal, then open System Preferences, Network, and do what member osxx said.

Mine looks like this, and yes I recall it used to be called 'Airport'.

The router address is what you should paste into your Safari address bar to access the router's utility as harryb2448 was explaining.

Screen Shot 2011-11-24 at 21.01.45.png
 
OP
I
Joined
Nov 21, 2011
Messages
10
Reaction score
0
Points
1
Thanks for all the help guys.

looks like clicking "Turn Airport Off" whenever I'm done using the computer, then turning it on again does the trick.
 
Joined
Nov 28, 2007
Messages
25,564
Reaction score
486
Points
83
Location
Blue Mountains NSW Australia
Your Mac's Specs
Silver M1 iMac 512/16/8/8 macOS 11.6
Well always personally turn it on in System preferences and turn off in Menu Bar, if you have show status in menu Bar selected.
 
OP
I
Joined
Nov 21, 2011
Messages
10
Reaction score
0
Points
1
So after a week of successfully connecting to the airport using the "turn airport on/off" method, I'm having the same issues again!!

Seems like when the airport self assigns an IP address, it starts w/ 169 and doesn't connect. When it finally chooses to connect, the IP address starts w/ a 192.

I just don't get it. Do you guys think it's a faulty airport card?
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top