F1-F9 keys are not working on Windows partition

Joined
Sep 4, 2012
Messages
4
Reaction score
0
Points
1
Your Mac's Specs
iMac & MacBook Pro, ML OS
Hi everybody.
I run Win7 Ultimate 64 on a partition of my iMac 27" 3.4 Intel Core i7 and recently upgraded into Yoshemite.
Some two weeks ago, I was trying to configure my keyboard on a game playing on Windows (the only reason that I installed Windows to be honest, just to play Medieval Total War) and after the controls' change, my HotKeys controls on the Windows, stopped working (controlling brightness, sound etc).
I've tried everything -I know-, updated all drivers, using the FN key, and ticking the box with "Use all F1, F2, etc. keys as standard function keys." also in both boots without result.
It is not of any big crisis (after-all, it is the Mac that I use the most) but it is mind-bending to find out why and fix it.
Mind that while on Mac, the Fkeys work properly.
Any help would do.

Many thanks in advance.

Processor Name: Intel Core i7
Processor Speed: 3,4 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 8 MB
Memory: 32 GB
 
Last edited:

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,247
Reaction score
1,834
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
Open Control Panel while in Windows 7 and select Boot Camp. Check for any Boot Camp updates. I don't know if there are any but since you updated to Yosemite, you may also need to update drivers for Windows 7.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top