Date localisation in Excel 2008

Joined
Jul 23, 2008
Messages
2
Reaction score
0
Points
1
Hello all,
I have a problem with Excel 2008 on Leopard.

Basically when I enter dates in my local format dd/mm/yyyy, selecting Date as the format of the cell causes it to be displayed in US (mm/dd) format.
See pic:

w89abm.png


I have my international settings set to UK and this works in other apps. Excel seems to ignore the setting.

Is it possible to change the default Date format used in Excel?
This all works as expected in Windows :(

Cheers!
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,248
Reaction score
1,831
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
Well, it has me stumped too! I just searched throughout preferences and could not find anything referring to setting date or time format. I'm assuming Office 2008 should get its date and time from "International Settings" as other applications do.

(Be sure to download and install any updates or service packs from MS if you have not already.)

The only suggestion I can give is to refer you to the MS Office 2008 public forum and see if you can get an answer there:

https://www.microsoft.com/mac/help.mspx?app=1

Regards.
 
OP
R
Joined
Jul 23, 2008
Messages
2
Reaction score
0
Points
1
Thanks chscag! Glad it's not just me being a numpty to be honest! Will give it a couple of days just in case the answer pops into my head while eating breakfast or something then head over to the MS forum.

:)
 
Joined
Jun 26, 2008
Messages
345
Reaction score
22
Points
18
Location
Mississippi
Your Mac's Specs
iMac and Macbook
I was told that Mac reads certain date formats differently. I keep a large membership database for an organization and the expiration dates are often incorrect. The PC shows expiration in 2008, for example, and on my MAC it shows 2013. It has something to do with the manner in which dates are entered but I can't for the life of me understand why it has to be this way. It is awful to have to still depend on my PC for this database.
 
Joined
Jan 24, 2010
Messages
1
Reaction score
0
Points
1
Applying DD/MM/YY as the default date format in Excel 2008 for Mac

Hi All,

Try the following : Apple Menu / System Preferences / International / Formats / "Customize..." (under the Dates section) :

SysPref%20screenshot.png


This screen allows you to drag the date elements (such as day and month) to arrange your own desired format (such as DD/MM/YY). Once you've done this, restart Excel 2008 and you should now be able to always type your dates in Excel in this format.

Excel%20screenshot.png


This works for me and I am using Mac OSX 10.5.8 and Microsoft Excel 2008 for Mac v12.0.
 
Joined
Jun 26, 2008
Messages
345
Reaction score
22
Points
18
Location
Mississippi
Your Mac's Specs
iMac and Macbook
I understand your directions. But, what can I do on my end (with a Mac) when a PC person sends me the membership list? Do I have to tell him to go back and enter every expiration date (thousands) in a different format? Why does it have to be this way?
 
Joined
Jun 13, 2010
Messages
2
Reaction score
0
Points
1
Excel Mac - Setting European date format:

Excel Mac - Setting European date format:
The most important point is to RESTART Excel after setting the Region Format to United Kingdom in the Formats section of Language and Text under System Preferences. It wont change unless you restart Excel.
System Preferences==>
Personal==>Language and Text==>
Formats==>
Region==>United Kingdom==>
Restart Excel
 
Joined
Aug 11, 2010
Messages
1
Reaction score
0
Points
1
Solution did not work for me. Mac is displaying dates correctly but not Excel. I can customise dates dd/mm/yy but it is a pain
 
Joined
Jan 3, 2014
Messages
1
Reaction score
0
Points
1
Hi,
I'm new to joining the forums but have been browsing from time to time. I've noticed this thread because I too have been having a similar problem. I was preparing files to import into Fortora Fresh Finance, and noticed that when copying dates from the file I had been fixing on a Windows PC and copied it to the Excel I have on my mac, the dates seemed to completely change randomly. After doing some looking into it, I found out why.
In the Calculation section in your Excel program (I use 2008 on Mavericks), you'll notice a section called Workbook options. The configuration you would be after here is called "Use the 1904 date system". Hover over this config to see what it is, but UNTICKING this means it will then retain the dates expected.
This is however, only on a workbook by workbook basis... I haven't yet found out how to make it default, if you can at all. I suspect it's simply a case of Mac Vs Windows settings.
In any case, I hope this helps.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top