Charging Issues

Joined
Sep 11, 2014
Messages
23
Reaction score
1
Points
3
Your Mac's Specs
MacBook Pro 13" 2012, 2.5 GHz i5, 16 GB RAM, 512 GB SSD, Dual 25" Displays
Hi guys,

I have a 2010 15" MBP that has some issues with charging. It seems that it does not work without being plugged in via MagSafe, it does not work on battery power, cannot turn on, and shuts down if the MagSafe is removed. The light in the MagSafe is green, even though the battery is not at 100%. Cycle count on the battery is 186, condition is normal, does not charge. I have tried another working battery in it, but this does not fix it. I reset the PRAM, SMC, and checked the battery connection with the motherboard. Any ideas? Could it be the MagSafe port board, or is this a motherboard issue?
 
Joined
Jul 24, 2013
Messages
5,084
Reaction score
789
Points
113
Location
Ohio (USA)
Your Mac's Specs
2023-14" M3max MBPro, 64GB/1TB, iPhone 15 Pro, Watch Ultra
What version of OS X are you running? I had a battery charging issue on a 2009 Macbook that I had loaded Yosemite on. I had 10.10.0 on it. All looked good then the next day the battery icon had an "x" on it and would not charge. I had to have it plugged into it's charger but it would show a green light.

I downloaded and installed the Yosemite update 10.10.1 and reseated the battery, reset the SMC and all was good.

Of course if you are not running Yosemite this is a mute point. The other option is a bad MagSafe board problem or logic board. You can get a MagSafe DC-in board from ifixit.com. If it is a logic board might be time for a new laptop.

https://www.ifixit.com/Guide/MacBoo...Mid+2010+MagSafe+DC-In+Board+Replacement/3098

Lisa
 
OP
B
Joined
Sep 11, 2014
Messages
23
Reaction score
1
Points
3
Your Mac's Specs
MacBook Pro 13" 2012, 2.5 GHz i5, 16 GB RAM, 512 GB SSD, Dual 25" Displays
What version of OS X are you running? I had a battery charging issue on a 2009 Macbook that I had loaded Yosemite on. I had 10.10.0 on it. All looked good then the next day the battery icon had an "x" on it and would not charge. I had to have it plugged into it's charger but it would show a green light.

I downloaded and installed the Yosemite update 10.10.1 and reseated the battery, reset the SMC and all was good.

Of course if you are not running Yosemite this is a mute point. The other option is a bad MagSafe board problem or logic board. You can get a MagSafe DC-in board from ifixit.com. If it is a logic board might be time for a new laptop.

https://www.ifixit.com/Guide/MacBoo...Mid+2010+MagSafe+DC-In+Board+Replacement/3098

Lisa


Thanks for the suggestions, unfortunately this issue was occurring in Mavericks and Yosemite, so it does not seem to be a software issue. I think I will try the MagSafe board as it is least expensive.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top