AUTOMOUNT not working?

Joined
Jan 6, 2015
Messages
1
Reaction score
0
Points
1
Hi All,

I have been trying to mount a NAS share as a volume on my Macbook Pro retina running OSX Yosemite 10.10.

I have done the following...

In Auto_Master I have added the last line

#
# Automounter master map
#
+auto_master # Use directory service
/net -hosts -nobrowse,hidefromfinder,nosuid
/home auto_home -nobrowse,hidefromfinder
/Network/Servers -fstab
/- -static
/- auto_afp -nobrowse,nosuid

I have created the following file auto_afp with one line...

/../Volumes/Images -fstype=afp,noowners,nolockd,noresvport,hard,bg,intr,rw,tcp,nfc afp://username:password@NAS001/Images


Then a:

sudo automount -vc

The volume is created under /volumes but I cannot see anything in the images drive?

Can someone please help? What am I doing wrong?

Thanks for any help! :)
 
Joined
Mar 19, 2018
Messages
1
Reaction score
0
Points
1
Did you ever find a solution to this?

Did you ever find a solution to this?

Hi All,

I have been trying to mount a NAS share as a volume on my Macbook Pro retina running OSX Yosemite 10.10.

I have done the following...

In Auto_Master I have added the last line

#
# Automounter master map
#
+auto_master # Use directory service
/net -hosts -nobrowse,hidefromfinder,nosuid
/home auto_home -nobrowse,hidefromfinder
/Network/Servers -fstab
/- -static
/- auto_afp -nobrowse,nosuid

I have created the following file auto_afp with one line...

/../Volumes/Images -fstype=afp,noowners,nolockd,noresvport,hard,bg,intr,rw,tcp,nfc afp://username:password@NAS001/Images


Then a:

sudo automount -vc

The volume is created under /volumes but I cannot see anything in the images drive?

Can someone please help? What am I doing wrong?

Thanks for any help! :)
 
Joined
Jan 1, 2009
Messages
15,633
Reaction score
3,974
Points
113
Location
Winchester, VA
Your Mac's Specs
MBP 16" 2023 (M3 Pro), iPhone 15 Pro, plus ATVs, AWatch, MacMinis (multiple)
If what you want to do is to mount the NAS when you log in, the easiest way is to use System Preferences/Users & Groups to open your account, Unlock it with the lock icon and an admin password, then go to Login Items and drag into the window the mounted link you want to auto open. Then click on the Hide box for that action and re-lock the account information by clicking the padlock again. Now when you log in, the NAS should mount, but Finder won't open to it. If you DO want Finder to open the NAS, then un-hide it by unchecking the Hide box. I mount two NAS shares by this method and after boot I have the two icons for the NAS on my desktop.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top