Automator Help

Joined
Jun 27, 2008
Messages
12
Reaction score
0
Points
1
Dear all,

I am after making an automator that would put my machine to sleep after 30mins of running the automator. I know this can be set-up in the Energy settings the problem is that I need to be running a USB device for 30 mins after I press the Automator workflow and then let the machine go to sleep. Can any one shine some light on this?. Thanks

df
 
Joined
May 14, 2009
Messages
2,052
Reaction score
136
Points
63
Location
Near Whitehorse, Yukon
Your Mac's Specs
2012 MBP i7 2.7 GHz 15" Matte - 16 GB RAM - 120 GB Intel SSD - 500 GB DataDoubler Mac OS 10.9
Don't really know what you are trying to do,
Have you tried adding the actions "Pause" and "Sleep" somewhere into the script?
I made a example automator script, see if it can help.
Pause&Sleep.workflow.zip
 
OP
D
Joined
Jun 27, 2008
Messages
12
Reaction score
0
Points
1
Hi,

You hit the nail on the head. What I want is the machine to go to sleep 30 mins after I run the Automator. Problem, the action "Sleep" is no where to be found and when I load the script you sent me it says the action "Sleep" could not be loaded because it could not be located, try to re-install the action. Any thought?

df
 

Slydude

Well-known member
Staff member
Moderator
Joined
Nov 15, 2009
Messages
17,664
Reaction score
1,121
Points
113
Location
North Louisiana, USA
Your Mac's Specs
M1 MacMini 16 GB - Ventura, iPhone 14 Pro Max, 2015 iMac 16 GB Monterey

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top