Applescript appears garbled

Joined
Jan 14, 2011
Messages
2
Reaction score
0
Points
1
I have several Applescripts that wrote recently that work perfectly but when I open them in Script Editor they look garbled.

Here is an example snippet:

--find the line that the thumbs tag is on
«event R*chFind» thumbsLine with «class SelM» given «class FnIn»:text 1 of «class TxtW» 1, «class Opts»:{«class SMod»:text, «class STop»:true, «class Rvrs»:false, «class Case»:false, «class Wrds»:false, «class ExSl»:false}
copy the «class SLin» of «class pusl» of window 1 to thumbsLineCount

This is what it's supposed to look like:

--find the line that the thumbs tag is on
find thumbsLine searching in text 1 of text window 1 options {search mode:text, starting at top:true, backwards:false, case sensitive:false, match words:false, extend selection:false} with selecting match
copy the startLine of selection of window 1 to thumbsLineCount

Sometimes Script Editor will open them fine and sometimes they're all garbled. I'm on Yosemite with all the latest updates.

Does anyone know what's going on?

Thanks
 

vansmith

Senior Member
Joined
Oct 19, 2008
Messages
19,946
Reaction score
583
Points
113
Location
Queensland
Your Mac's Specs
Too many devices to list
When was the last time that you opened them? Were these compiled at some point? It looks like things have been partially translated.

Do you have a backup?
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top