• The Mac-Forums Community Guidelines (linked at the top of every forum) are very clear, we respect US law and court precedence when it comes to legality of activity.

    Therefore to clarify:
    • You may not discuss breaking DVD or BluRay encryption, copying, or "ripping" commercial, copy-protected DVDs.
    • This includes DVDs or BluRays you own. Even if you own the DVD or BluRay, it is still technically illegal under the DMCA to break the encryption. While some may argue otherwise, until the law is rewritten or the US Supreme Court strikes it down, we will adhere to the current intent of the law.
    • You may discuss ripping or copying unprotected movies or homemade DVDs.
    • You may discuss ripping or copying tools in the context that they are used for legal purposes as outlined in this post.

Apple DVD Player quit on me....



Apple's DVD Player app recently quit on me. Clicking on it, or inserting a DVD, sees it begin to load and then immediately quit. It bounces on the dock for about 1/2 a second and then disappears. Checking the error logs I found this:
Date/Time: 2004-04-15 01:39:22 +0900
OS Version: 10.3.3
Report Version: 2

Command: DVD Player
Path: /Applications/DVD Player.app/Contents/MacOS/DVD Player
Version: ??? (???)
PID: 503
Thread: Unknown

Link (dyld) error:

dyld: /Applications/DVD Player.app/Contents/MacOS/DVD Player can't open library: /System/Library/PrivateFrameworks/HIServices.framework/Versions/A/HIServices (No such file or directory, errno = 2)

When I look under the above (System/library/privateframeworks/...there is no HIServices.framework.
I have done a search and deleted all files associated with DVD Player, then reinstalled off of Apple's website. I also tried a "Software Restore" off of my system Cds. Nothing seems to work.
I can't even get into the program to try and play around with preferences etc.
Does anyone have any idea what I could have done?
Thanks for you help,

P.S. I always try to think of recent installs etc. that might have been a catalyst.
Following advice from the March 2004 MacHome Magazine "Spring Cleaning" column I erased all receipts in my System/Library folder. This was VERY BAD advice. Thereafter I couldn't perform Permission repairs, and was forced to download updates to several hardware devices that were already up to date. Anyways, reprecussions continue to trickle in. I would NEVER screw around in my Systems folder, but I thought I could trust the mag....BIG mistake, one VERY UNHAPPY customer....oh, and they got a letter too ;)
Thanks again,
Mar 9, 2004
Reaction score
Miami FL
Your Mac's Specs
G4 1Ghz OS X 10.4.7
That must be very frustrating. If repair permissions can't work maybe it's time to boot in single user mode (hold command S after tone) and type fsck until ****FILE SYSTEM CHANGED**** stops showing


I had the same problem as you did with Apple’s DVD app - The DVD player icon bounced in the dock for about 1/2 a second and then quit.

I was searching around, and here is the solution that worked for me:

Download the dvdplayerextractor.sh.zip from the above link and run the script. You need to have the OSX Install Disc 1 in first before you run the script. After the script is done everything should be fixed.

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.