Adwware - com.genieoinnovation.Installer

Feb 11, 2015
Reaction score

I downloaded an installer for Coconut battery from When I tried to run the .dmg I got an installer program which asked me to double-click on a package. No installation started. I (forced) ejected and tried again, same thing. I downloaded the file from softonic again, tried to install again, same thing happened. No Coconut Battery installed. No installation started at all... seemed to just freeze. Anyway, I got concerned and downloaded Sophos Anti-virus, which found a threat with the coconut-battery installer.dmg and labelled it as Genio installer, which I now know is Adware. I searched various websites, found none of the issues associated with Genieo. So, possibly no Genieo installation? Hopefully...
Console shows the following:
Process: Installer [457]
Path: /Volumes/*/
Identifier: com.genieoinnovation.Installer
Version: 2.0 (2)
Code Type: X86-64 (Native)
Parent Process: launchd [138]
Responsible: Installer [457]
User ID: 501

Date/Time: 2015-02-11 18:02:18.599 +0000
OS Version: Mac OS X 10.9.5 (13F34)
Report Version: 11
Anonymous UUID: 376A20A0-0EFC-52F8-3BE9-94172768C0B8

Crashed Thread: 10 Dispatch queue: NSWorkspace Volume Observer Queue

Exception Codes: 0x000000000000000a, 0x00000001000269f5

This message appears for the three times I tried to install the software. So, can someone tell me if this message indicates that the software, Genieo, is not installed? There's no sign of it on my system, Sophos is not finding anything after system scan and no files that people list associated with Genieo can be found. I've looked at removal processes from several websites and none of the files or extensions mentioned can be found on my system. Can it still be hiding somewhere?
I started getting prompts to enter password for iCloud, not sure if that's related. I signed-out of iCloud now.

Thanks for any insight anyone can provide.

MacBook Air, OS X Mountain Lion (10.8.5)
Nov 28, 2007
Reaction score
Blue Mountains NSW Australia
Your Mac's Specs
Silver M1 iMac 512/16/8/8 macOS 11.6
Download AdwareMedic from this link and run that to remove the Geneio malware, and any others you have picked up.

Secondly never download from softonic or cnet as they include this type of malware rubbish with downloads that install without your knowledge or consent.


Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.