Western Digital MyBook My Studio 1TB problem

Mar 18, 2010
Reaction score
Hey everyone!

I'm having issues with my WD MyBook MyStudio. Yesterday, I erased the drive for a fresh start with my hard drive. After I had done this, some data was added to the drive. So basically I have an empty drive, that is however still filled with over 600MB of unknown data. This used to be about 200MB, and I assumed this was the data taken by the virtual SmartWare software. But after erasing the drive, it added 400MB.

So I tried to get rid of that data by removing the partition and adding a new fresh one. I tried this several times and it doesn't help me to get rid of my problem. Instead, everytime I repartition or reformat my drive, new files are added to the system. I can see that there are 43 files on my external HDD, but I can't find them. The little screen on my hard disk used to say "999GB FREE", now that has lowered to "998GB FREE".

How do I get rid of this extra and unwanted data?

Secondly, when I opened SmartWare, it used to divide my MyBook into several segments such as "Pictures", "Movies", "Music", "Other" etc. Now all of these are gone and all that remains is "Additional Files".

How do I fix this?

Thirdly, since I reformatted the drive, the icon that appears on my desktop has changed.

How can I return the icon to its original state?

Thanks in advance,


Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.