websites load very slowly!

Joined
Jul 2, 2009
Messages
5
Reaction score
0
Points
1
I have a 15" MacBook Pro 2.4 GHz (model MacBookPro3,1). I recently bought a Belkin n150 enhanced wireless router to use with it. It connects alright, but loading ANY page takes a very long time. I did a speed test, which came up normal, meaning downloads and uploads are the correct speed, but opening websites is very slow. Even opening the settings page for the router takes much longer than expected. I'm using WPA-2 personal security. One other odd thing, my iPhone has no problems whatsoever with this router. Connects and loads quickly. If anyone has an idea, let me know. If I've left out any pertinent information, just ask. Thanks!
 

vansmith

Senior Member
Joined
Oct 19, 2008
Messages
19,924
Reaction score
558
Points
113
Location
Queensland
Your Mac's Specs
Mini (2014, 2018, 2020), MBA (2020), iPad Pro (2018), iPhone 13 Pro Max, Watch (S6)
It could very well be your DNS settings. Try changing to something like OpenDNS to see if that fixes it.
 
Joined
Oct 22, 2007
Messages
8,967
Reaction score
287
Points
83
Location
London
Your Mac's Specs
Mac Mini Core i7 2012 | White 2009 MacBook 2 Ghz | 733 Mhz G4 Quicksilver
Where are you, and which DNS service are you using. Have you set up your ISP's DNS servers on the routers's configuration.
 
OP
K
Joined
Jul 2, 2009
Messages
5
Reaction score
0
Points
1
I'm in Ohio. AT&T says to automatically receive DNS info from the server itself, so that's what I was doing. I tried having the router go through OpenDNS, but that was no help at all.
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,249
Reaction score
1,829
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
I'm in Ohio. AT&T says to automatically receive DNS info from the server itself, so that's what I was doing. I tried having the router go through OpenDNS, but that was no help at all.

It's not just the router that must be set to Open DNS you need to likewise change the DNS settings in: System Preferences -> Network -> Advanced -> DNS Tab.

First address is your router (ignore it). It's the next two that you must change to Open DNS.

Regards.
 
Joined
Jul 2, 2009
Messages
1
Reaction score
0
Points
1
knupdiputs:

how did u change it to OPEN DNS?? I am having the same problem with pages loading very slow all of a sudden. :(
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,249
Reaction score
1,829
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
Start by going to the OpenDNS home page and go through their tutorial step by step. They have instructions for Mac hardware.

Regards.
 
Joined
Oct 2, 2009
Messages
2
Reaction score
0
Points
1
Your Mac's Specs
Mac OX X 10.5.8 (2 GHz 1GB)
OpenDNS totally worked for me. The websites that took FOREVER to load are now loading like other sites with no issues. Thanks for the info :) .
 
Joined
Oct 2, 2009
Messages
2
Reaction score
0
Points
1
Your Mac's Specs
Mac OX X 10.5.8 (2 GHz 1GB)
do u have to create a DNS account? it seems like they could spy on your every move...i don't know

You do have to create an account but it took me only a few minutes and I am not computer literate AT ALL :Oops: . I was worried about being "spied" on too, but I just can't deal with the slow loading any longer.

Maybe someone can chime in and let us know that OpenDNS is safe and we won't be compromised in any way...?
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top