Web browsers cannot connect to server google/yahoo/youtube.com? help

Joined
Sep 25, 2011
Messages
6
Reaction score
0
Points
1
When trying to get to google.com/youtube.com/yahoo.com I keep receiving the message "Safari can't connect to server" I then tried the same operation in firefox and a similar message.

Other sites are able to be accessed without issue...

This has been happening for a few months now but I usually can fix this issue for a period of time by deleting my cache files. But this no longer has the same effect.

I also tried safari's help link of Try entering “/index.html” at the end of the address.This also has no effect..

also found this odd... I tried to access my mail through yahoo and was able to get to it by entering yahoo.com/mail ???

Any help would be appreciated.
 
Joined
May 19, 2009
Messages
8,428
Reaction score
295
Points
83
Location
Waiting for a mate . . .
Your Mac's Specs
21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
Try this for Safar as you might have a corrupt .plist and i don't use FF so can't be of help there
Quit safari
Open Finder then to Go in the menu bar. Now press Option and you will see yourLibrary appear in the drop down. Now click that and Finder will now show the hidden Library Folder. Goto Preferences and look for or type in the spotlight bar com.apple.safari.plist
Now drag that to your Desktop.
Relaunch Safari and a new .plist will be made within the Preferences folder and hopefully that has solved the problem.
If not Find the new Safari.plist drag it to the trash and replace it with the old one from the desktop.
 
OP
M
Joined
Sep 25, 2011
Messages
6
Reaction score
0
Points
1
Hey thanks for answring ...but is there any other way to find that .plist folder? I tired pressing option and click the go button but no hidden library showed. So I then found figured out how to show hidden files with a terminal command, but i still was unable to find that folder?

:edit: Actually I found the file and removed it ...but no luck
 
Joined
May 19, 2009
Messages
8,428
Reaction score
295
Points
83
Location
Waiting for a mate . . .
Your Mac's Specs
21" iMac 2.9Ghz 16GB RAM - 10.11.3, iPhone6s & iPad Air 2 - iOS 9.2.1, ATV 4Th Gen tvOS, ATV3
Hey thanks for answring ...but is there any other way to find that .plist folder? I tired pressing option and click the go button but no hidden library showed. So I then found figured out how to show hidden files with a terminal command, but i still was unable to find that folder?

And that be my fault presuming you where running Lion. My apologies for the mis-leading information . . . . .

Try Repairing Permissions in Disk Utility via Applications>Utilities

Click on yourHD in the left column and the click the First Aid tab.
Now at the bottom of the window click Repair Permissions. This can take a while if the System is a little messy. Once done restart and hopefully that has done something.

Cheers
 

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
15,817
Reaction score
2,170
Points
113
Location
MA
Your Mac's Specs
2022 Mac Studio M1 Max, 2023 M2 MBA
Open up a terminal and enter the following command and tell us what you get
Code:
ping -c5 google.com
traceroute google.com

Do the same 2 commands for the other URL's you are having issues with. Also do those commands with URLs that do work just for comparison..
 
OP
M
Joined
Sep 25, 2011
Messages
6
Reaction score
0
Points
1
Thank you for responding:
I ran

1.ping -c5 google.com

and completed with :
5 packets transmitted, 5 packets received, 0.0% packet loss
round-trip min/avg/max/stddev = 11.744/12.377/12.660/0.325 ms


Same for youtube.com, yahoo.com
Did not complete
2.traceroute google.com

traceroute: sendto: No route to host
-traceroute: wrote google.com 52 chars, ret=-1


Same message for all sites including the sites that work
 
OP
M
Joined
Sep 25, 2011
Messages
6
Reaction score
0
Points
1
Need help removing Torjan (BASH/QHost.WB)

After having issues with certain pages not connect to servers especially anything google.com or owned by them and others. I found users with similar problems and the cuplprite seems to be a Trojan called BASH/QHost.WB with a link to the founders here Threat Description: Trojan:BASH/QHost.WB. Now I need to remove this file but the directions given by the site (pasted below) aren't working.

I ran $cd /private/etc
and got operation complete

Then tried to run
$sudo vim hosts
and no result but after one time I was asked for my admin password which I stupidly gave then changed right after.
I do not get anything like :
91.224.160.26 google.com
91.224.160.26 google.ae
91.224.160.26 google.as

Manually correcting the hosts file

1. Open terminal and change directory to */private/etc/*

$cd /private/etc

2. Use any editor tool you prefer and edit the *hosts* file. Note: You need root privilege to do this.

$sudo vim hosts

You should see something similar to the following:

91.224.160.26 google.com
91.224.160.26 google.ae
91.224.160.26 google.as

[truncated for brevity]

3. Remove all the entries contain *91.224.160.26* from the hosts file.
 

dtravis7


Retired Staff
Joined
Jan 4, 2005
Messages
30,133
Reaction score
703
Points
113
Location
Modesto, Ca.
Your Mac's Specs
MacMini M-1 MacOS Monterey, iMac 2010 27"Quad I7 , MBPLate2011, iPad Pro10.5", iPhoneSE
I hope you are not putting in the $ first thing. Second you HAVE to give OSX your admin password to run Vim and other editors. You are giving the OS the Root Password. That is the way Unix OS's work and why they are more secure.

I just tried it here like this:

Open the Terminal in Utilities.
type in:

cd /private/etc

then type:

sudo vim hosts

It will ask your OSX Administrator Password. Give it that and the editor will open with the hosts file.


Here is what a proper hosts file looks like.........................

#
# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost
~
~
~
~
~
~
~
~
~
~
~
~
~
"hosts" 10L, 236C



I believe it's Command+s to save. It's Command+q to quit vim.
 

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
15,817
Reaction score
2,170
Points
113
Location
MA
Your Mac's Specs
2022 Mac Studio M1 Max, 2023 M2 MBA
Slight clarification on Dennis' post..you have to give OS X your password when you prefix a command with "sudo", indicating that you want to run the command as Root..

Please do the following
Code:
cat /private/etc/hosts
This will show you the contents of the hosts file, you indeed see the offending contents in there, you will want to delete them with
Code:
sudo vi /private/etc/hosts
Enter your password to allow this action. Once VI starts up, use the cursors to scroll to the first offending line, now hit 'd' key twice. The line will now be deleted. You can now repeat this command on other offending lines (scroll using the cursor if need be) by hitting the '.' (period) key on the keyboard or hid the 'd' key twice again.

Continue doing this until your hosts file is clean and looks more like what Dennis has put on his post.

Once you're done, you want to save the file and quit VI. To do so, you'll want to hit the ':' (colon) key, that is, hold down the SHIFT key and hit the semi-colon ';' key. Now enter the letters 'wq' and hit enter. This will [w]rite the file and [q]uit VI.

Now please test your access to the sites you were having issues with previously..
 
OP
M
Joined
Sep 25, 2011
Messages
6
Reaction score
0
Points
1
Once again thank you. Im glad i didn't give the trojan my password. But it looks like I am not infected with this torjan than because mine looks just like dtravis7 host file, with the only exception being the bottom. So im seems unfortunately im back to square one again with this issue.

# Host Database
#
# localhost is used to configure the loopback interface
# when the system is booting. Do not change this entry.
##
127.0.0.1 localhost
255.255.255.255 broadcasthost
::1 localhost
fe80::1%lo0 localhost
~
~
~
~
~
~
~
~
~
~
~
~
~
"/private/etc/hosts" 10L, 236C

I just thought to try and use a proxy server to use these sites and it works. Idk if that would lead to a clue or not to my issue?
 

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
15,817
Reaction score
2,170
Points
113
Location
MA
Your Mac's Specs
2022 Mac Studio M1 Max, 2023 M2 MBA
What proxy server? How long has this issue been happening and how are you connected to the Internet?
 
Joined
Sep 30, 2011
Messages
2
Reaction score
0
Points
1
I have been having the same issue for a week or so now. I have cycled the router and modem and I have used another laptop on the same IP and been able to access google, yahoo, and youtube. Interestingly enough I am able to access google if I go through a proxy site like hidemyass.com. My hosts file appears normal and I have no entries referring to google. The issue is the same on Firefox and Safari. I am connected through DSL. I really hope someone can help us out here.
 
Joined
Sep 30, 2011
Messages
2
Reaction score
0
Points
1
I figured it out. Peer Guardian had apparently updated and messed things up a bit. I disabled the filters and now everything is back to normal.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top