Very Broken MacBook (file system errors, won't boot)

Oct 27, 2011
Reaction score
Hi all!

I'm normally very good to my computer, but lately it seems to be on the fritz in a big way. I've looked for others with similar problems and havent found anything. I think it might be a compounding of issues.

I have a mid-2007 black Macbook, running Snow Leopard and boot camped with Windows XP.

It won't boot SL. I press the power button, it turns on, the grey apple and the wheel show up....with a grey progress bar. The progress bar VERY SLOWLY (takes about 5 minutes) gets moving, and then suddenly disappears. The grey apple and the wheel stay. I've let it sit like this for 20 minutes with no progress.

I tried a RAM reset. No change. I tried booting in safe mode, it just reboots itself. I can boot to my Leopard OS disks (Not SL, I can't find them) and run Disk Utility...but...

It fails on both repairs and verifys. The actual red errors change every time, but it always says "Incorrect block count for file MobileDevice." I recently did an update for my iPhone, with an update for iTunes. It started behaving sort of strangely and slowly after that. Eventually it crashed and I had to hard reset and this whole mess began.

I would simply reinstall leopard, but for some reason my mac drive won't mount. The only option I have for an install is on my windows partition.

I have read recommendations for fsck, but I can't boot in single-user mode, and typing it into the CD booted terminal seems to do nothing.

So, a lot of problems here on a relatively old machine. Any ideas?

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.