Upgrade to Yosemite got me stuck on white screen

Mar 20, 2015
Reaction score
Dear readers,

I am new to the forum, but I have an enormous problem. Actually my wife has the problem.

She upgraded her MacBook Pro 2009 with Mavericks accidently to Yosemite. Now there is nothing wrong with that and it should be able to run, but either there was a faulty install or maybe the battery ran low or something else happened. Now it does nothing!

I boot and I see a white screen. I tried booting with special commands, holding SHIFT, CMD+R, CMD+SHIFT+APPLE, but none of those seem to have any effect. Every reboot I get the same. It turns off instantly when I press the ON/OFF button. It boots instantly to white screen when I press it again. It doesnt do anything and maybe after a minute or so, a big folder appears blinking in the center of the screen with a question mark in it.

I have no idea what to do, but I want to fix this for her since she needs the documents on it. She uses it daily for her job. I have tried to disconnect the battery and it has no effect. Does anybody know how to fix this?

Thanks for your time
Nov 28, 2007
Reaction score
Blue Mountains NSW Australia
Your Mac's Specs
Silver M1 iMac 512/16/8/8 macOS 11.6
G'day and welcome to the forums.

Did yur wife see the cmp;lete download and the white screen with the loading bar? If it went twhite then, simply power down and boot again. An SMC reset may help if no joy. Power down, unplug frm the mains for ten minutes or so, connect back up and boot.

Keep us posted?

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.