"Unable to verify identity of website" message

Joined
Oct 9, 2014
Messages
3
Reaction score
0
Points
1
Randomly last week I started getting this "Unable to verify identity of website" message on almost any websites I visit in Safari. I reset Safari settings and it did not fix it. I'm on OS X 10.9.5 on a MacBook Pro from 2010. I've tried "allowing" these certificates but nothing works.

Has anyone seen this before? Thanks in advanced for your help!
 
Joined
Jul 24, 2013
Messages
5,083
Reaction score
787
Points
113
Location
Ohio (USA)
Your Mac's Specs
2023-14" M3max MBPro, 64GB/1TB, iPhone 15 Pro, Watch Ultra
Hi!

Okay first make sure your date and time on your machine is set correctly. Sometimes if the automatic date box is unchecked that can cause a problem. If the date and time are off the certificates will not be accepted.

If that does not work try this:

From the Safari Menu Bar click Safari/Reset Safari. Select all the boxes. Then from the Menu Bar click Safari/Quit Safari.

Now relaunch Safari. Try logging into one of those sites.

If that didn't help, try troubleshooting the Safari .plist file.

Open a Finder window. Select your Home Folder in the Sidebar on the left. It has a small house icon. Then open the Library folder then the Preferences folder. Move the com.apple.Safari.plist file from the Preferences folder to the Desktop. Now launch Safari. Navigate to a site that normally has a signed certificate like your bank. If you can do this without the invalid certificate dialog, move that .plist file to the Trash.

If that didn't work you can try this:

From your Safari Menu Bar click Safari/Preferences then select the Security tab.
Click: Show Cookies. Delete all the cookies for the sites you have problems with certificates.

Now relaunch Safari and try one of those sites.

Hopefully this helps.

Lisa
 
OP
H
Joined
Oct 9, 2014
Messages
3
Reaction score
0
Points
1
Hi!

Okay first make sure your date and time on your machine is set correctly. Sometimes if the automatic date box is unchecked that can cause a problem. If the date and time are off the certificates will not be accepted.

If that does not work try this:

From the Safari Menu Bar click Safari/Reset Safari. Select all the boxes. Then from the Menu Bar click Safari/Quit Safari.

Now relaunch Safari. Try logging into one of those sites.

If that didn't help, try troubleshooting the Safari .plist file.

Open a Finder window. Select your Home Folder in the Sidebar on the left. It has a small house icon. Then open the Library folder then the Preferences folder. Move the com.apple.Safari.plist file from the Preferences folder to the Desktop. Now launch Safari. Navigate to a site that normally has a signed certificate like your bank. If you can do this without the invalid certificate dialog, move that .plist file to the Trash.

If that didn't work you can try this:

From your Safari Menu Bar click Safari/Preferences then select the Security tab.
Click: Show Cookies. Delete all the cookies for the sites you have problems with certificates.

Now relaunch Safari and try one of those sites.

Hopefully this helps.

Lisa

Great! That did it! I've been getting a message about my time being messed up as well. I just set the time and never looked at it again. But when I went back and checked the Auto-Time box was unchecked.

Thanks for you help. What could have caused this to happen randomly?
 
Joined
Jul 24, 2013
Messages
5,083
Reaction score
787
Points
113
Location
Ohio (USA)
Your Mac's Specs
2023-14" M3max MBPro, 64GB/1TB, iPhone 15 Pro, Watch Ultra
No idea unless an update did it .... or a computer gremlin.... hard to say. Glad that fixed it.

Lisa
 
Joined
Aug 19, 2014
Messages
792
Reaction score
4
Points
18
actually 10.9.5 likes to auto uncheck things after updating is all i ran into it on my mac pro this morning
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top