Trouble loading Mac-Forums from email link

Rod


Joined
Jun 12, 2011
Messages
9,524
Reaction score
1,779
Points
113
Location
Melbourne, Australia and Ubud, Bali, Indonesia
Your Mac's Specs
2021 M1 MacBook Pro 14" macOS 13, iPhone SE 2, iPad 6, Apple Watch SE.
Has anyone else had this problem with Brave browser? Of course I can't be sure it's limited to Brave but that's my default iOS browser.
When I click on an e-mail link to a new post Brave opens but will not load the page. There is a little exclamation mark top left with a partial progress bar, when I tap it I get this;

IMG_4294.jpeg

Turning Brave shields off does not prevent this but turning on my VPN does.

This in itself is interesting because to me this suggests that Brave recognises the anonymity or encryption created by a VPN as a increased security measure.

Below are my usual Brave Shield settings and I note that this is only happening with e-mail links to Mac-Forums. All other links open on Brave without problems but MF links are the most frequent email links I open.

IMG_4295.png

I'm not sure if I need "Block Fingerprinting" on, I've always had it on, could that be an issue?
Lastly, I don't recall the little exclamation mark icon on the search bar being present in the past, is this a new thing?
 

IWT


Joined
Jan 23, 2009
Messages
10,152
Reaction score
2,110
Points
113
Location
Born Scotland. Worked all over UK. Live in Wales
Your Mac's Specs
M2 Max Extra, 32GB memory, 4TB, Sonoma 14.3.1. Apple 5K Retina Monitor
Could this, in any way, relate to your dual habitation (ie Melbourne & Bali)? I was just thinking that maybe Brave is "confused" by the different locations; but recognises your VPN as a safety device irrespective of location??

This is not much help, I'm afraid, in part because I don't use Brave routinely although I have it as a backup browser.

Ian
 
OP
Rod

Rod


Joined
Jun 12, 2011
Messages
9,524
Reaction score
1,779
Points
113
Location
Melbourne, Australia and Ubud, Bali, Indonesia
Your Mac's Specs
2021 M1 MacBook Pro 14" macOS 13, iPhone SE 2, iPad 6, Apple Watch SE.
Thanks Ian, at first I thought it might be an expired SSL certificate for the site but iOS Brave has a function to check that and it shows as "valid". I don't think it's because of my "dual residency" but good lateral thinking on your part, I hadn't considered it.

This is what Brave says about this little "!" icon;

So it seems Brave considers the site insecure but I'm not sure why this has started happening recently as it did not happen before. Obviously something has changed with the site, browser or network.🤷🏼‍♂️

PS. What are you doing up at this time of night? 🙂
 

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
15,686
Reaction score
2,015
Points
113
Location
MA
Your Mac's Specs
2022 Mac Studio M1 Max, 2023 M2 MBA
The SSL certificate is valid until March 1, 2024. So not sure why you're getting that error, the side is indeed secure.
 
OP
Rod

Rod


Joined
Jun 12, 2011
Messages
9,524
Reaction score
1,779
Points
113
Location
Melbourne, Australia and Ubud, Bali, Indonesia
Your Mac's Specs
2021 M1 MacBook Pro 14" macOS 13, iPhone SE 2, iPad 6, Apple Watch SE.
Yep, that's what I get too;

IMG_4297.jpeg
IMG_4296.png
So, that makes me wonder about the browser settings. I might try backing off the security settings a little for this site.
 

IWT


Joined
Jan 23, 2009
Messages
10,152
Reaction score
2,110
Points
113
Location
Born Scotland. Worked all over UK. Live in Wales
Your Mac's Specs
M2 Max Extra, 32GB memory, 4TB, Sonoma 14.3.1. Apple 5K Retina Monitor
PS. What are you doing up at this time of night? 🙂

About the only time I get to myself to play (sorry, study) on my Mac :giggle:

Ian
 

Slydude

Well-known member
Staff member
Moderator
Joined
Nov 15, 2009
Messages
17,588
Reaction score
1,066
Points
113
Location
North Louisiana, USA
Your Mac's Specs
M1 MacMini 16 GB - Ventura, iPhone 14 Pro Max, 2015 iMac 16 GB Monterey
Sorry, I can't be much help here guys. >ail seems to dump all e-mails from Mac-Forums e-mails into my junk folder rather than the folder the mail rule is supposed to send it to.
 
OP
Rod

Rod


Joined
Jun 12, 2011
Messages
9,524
Reaction score
1,779
Points
113
Location
Melbourne, Australia and Ubud, Bali, Indonesia
Your Mac's Specs
2021 M1 MacBook Pro 14" macOS 13, iPhone SE 2, iPad 6, Apple Watch SE.
Well, changing security settings hasn't changed anything. What I have found is if I try the link twice it will load the page on the second try, the first attempt results in a blank page.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top