Setup Mocha VNC Lite with for remote access??

Oct 30, 2007
Reaction score
I am trying to remotely connect to my Macintosh while outside of my home network via my iPhone, using the newly released Mocha VNC Lite app released on the App Store last week...I can't seem to figure out what I am doing wrong and why I cannot get the connection to work properly, and I was hoping someone could give me a hand in figuring out what the problem might be...

I am trying to connect to my Leopard 10.5.4 desktop computer, on which I've enabled Remote Management in the Sharing System Preference Pane (not "Screen Sharing" for more technical reasons), and in the 'Computer Settings' options for Remote Management, I've entered in my chosen VNC password. +**Though I am not sure whether or not "Allow Access For All Users" has to be checked instead of what I currently have, which is "Only These Users..."+

I also have a paid account with with whom I've signed up for a Dynamic Domain Name Service.

I have also tried configuring my airport extreme to forward the necessary ports to my local desktop machine a couple different ways - I've tried using a random port between 30,000-50,000; and I've tried using the suggested port 5900, which is the default suggested by Mocha VNC Lite....I forwarded the ports mentioned to a static LAN IP address I've setup for computer...

...and for testing purposes, I have Leopard's firewall configured to "Allow All Incoming Connections"

Using VNC Lite, I entered in my Dynamic Domain Name into the 'VNC Server IP Address field (having tried a variety of alternate ways of doing so, such as - domainname.kicks-***.net -- http://domainname.kicks-***.net -- https://domainname.kicks-***.net -- vnc://domainname.kicks-***.net - vnc://domainname.kicks-***.net:LAN-IP - etc.) ...and yes, name.kicks-***.net is really one of the domain names they offer :)

In the VNC Server Port field I've entered in the port that I chose to forward in my airport extreme settings.

Finally I have "Mac OS Server" turned on, "Save Password" turned on, and "32-bit color mode" turned on...

Nothing I've been able to come up with has worked!!

Any suggestions would be greatly appreciated... Thanks!

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.