Screensaver in Yosemite

Joined
Feb 1, 2009
Messages
1
Reaction score
0
Points
1
Location
IL
My screensaver reverts to natgeo after I select Iphoto( last 12 Mos). I've reset several times, same results. Thoughts?
 
Joined
Oct 22, 2014
Messages
2
Reaction score
0
Points
1
Same problem here...trying to set screensaver to an iPhoto album, keeps reverting to NatGeo. Kinda frustrating.
 
Joined
Oct 22, 2014
Messages
3
Reaction score
0
Points
1
screensaver defaulting to Nat Geo

I also have the same problem, but only on my iMAC. My MacBook seems to work just fine.
 
Joined
Oct 22, 2014
Messages
3
Reaction score
0
Points
1
screensaver in yosemite

Also, (on the iMAC) the problem isn't just limited to iPhoto reverting back to NatGeo. If you pick any of the other default items, it will soon revert back to NatGeo from them.
 
Joined
Oct 27, 2014
Messages
1
Reaction score
0
Points
1
Have the same problem on my iMac , very frustrating . Using screensaver as image viewer from my last vacation.
 
Joined
Oct 29, 2013
Messages
7
Reaction score
0
Points
1
same thing here

I have an iMac. It's making me nuts. Not a big deal, but I want my photos not natgeo,
 
Joined
Nov 6, 2014
Messages
2
Reaction score
0
Points
1
screensaver in yosemite

me too. however, hot corners is still working for me.

i noticed this problem from the first day i downloaded yosemite, but i couldn't find anything online about it. glad to see others are noticing it.

i can set it to my iPhoto album, and it will continue to stay set until it fully sleeps. but after coming out of sleep, it's right back to natgeo.

any ideas?
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,249
Reaction score
1,829
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
It's a bug. Hopefully fixed in the next update to Yosemite.
 
Joined
Nov 2, 2012
Messages
383
Reaction score
1
Points
18
Your Mac's Specs
iMac 21.5" 2.5 i5 8G RAM OS X 10.10.3 (12C60)
While we're at it, does anyone know how to change the logon window's little round picture?

Actually, I think it's the screen right after the password is entered.
 
Joined
Nov 6, 2014
Messages
2
Reaction score
0
Points
1
UPDATE: i got it to work.

i didn't just change the folder location, but i changed the format to "vintage." now it is no longer reverting back to natgeo. hopefully changing the format will work for you, too.
 
Joined
Jul 26, 2013
Messages
10
Reaction score
0
Points
1
My Mac book pro has been fine after the Yosemite update until yesterday just started showing the natgeo stuff. Where's the vintage option?
 
Joined
Oct 22, 2014
Messages
3
Reaction score
0
Points
1
Consistent now

So, installed the Yosemite update yesterday, hoping it would cure the screensaver problem. All it did was make the problem consistent -- now does the same thing on my MacBook as on my iMAC (reverts back to NatGeo on screensaver). Suggestion by someone to try vintage didn't work either.
 
Joined
Nov 2, 2012
Messages
383
Reaction score
1
Points
18
Your Mac's Specs
iMac 21.5" 2.5 i5 8G RAM OS X 10.10.3 (12C60)
Where are you guys seeing options for the screen savers? I only see defaults to what they give you - no user choices.

Oh I see now...never mind.
 
Joined
Nov 23, 2014
Messages
1
Reaction score
0
Points
1
Same problem here

Same problem here. Trying the switch to Vintage and if that works I may try to go back to Ken Burns format just to see if the problem comes back.

Switch to Vintage didn't work for me. Still switching back to NatGeo.
 
Last edited:
Joined
Jul 26, 2013
Messages
10
Reaction score
0
Points
1
Mine only does this occasionally. When I go into the screen saver settings I see that my selections have been unchecked. I recheck and all is well. Till the next time which so far is only rarely.
 
Joined
Jan 22, 2015
Messages
2
Reaction score
0
Points
1
Screensaver defaults to natgeo

Scupper76 and dotdotdot, I'm having the same screensaver default back to natgeo, but I can't find vintage in the screensaver area. I tried the "help" function, w/no help. Can you tell me where that vintage option is in MacOS X?
 

Slydude

Well-known member
Staff member
Moderator
Joined
Nov 15, 2009
Messages
16,709
Reaction score
601
Points
113
Location
North Louisiana, USA
Your Mac's Specs
2.8 GHz 2008 MacBook Pro 10.11, 8 GB mem, iPhone 12 Pro Max, 2015 iMac 16 GB Big Sur
If you are looking at the Screensaver tab, Vintage is in the list on the left side. You may have to scroll down to see it,
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top