Screen sharing stopped working after 10.10.2 update

Feb 12, 2015
Reaction score
Screen sharing between my iMac and Mac Mini stopped working after I applied the 10.10.2 update. I'm trying to access the Mac Mini from the iMac. I get the standard error message advising that I should check the Mac Mini is on the network etc. etc.

File sharing works well. I can copy files between the two Macs and can move and delete files on the Mac Mini. I always access Screen Sharing using the same user credentials as for File Sharing.

I have tried:

  • Turned Screen Sharing off then on again on the Mac Mini.
  • Checked the IP address many times.
  • Invoked Screen Sharing using the application (in CoreServices), the Connect to Server dialog (command-k) and the Network dialog (command-shift-k).
  • My Mac Mini does appear under “Sharing” in the sidebar suggesting (with the working file sharing) that this is not a networking issue.
  • Reinstalled 10.10.2 using the combo updater.
  • Adding port 5900 to the vac command (i.e. vnc://nnn.nnn.n.nnn:5900).
  • Deleted the screen sharing prefs files (on the iMac).
  • Deleted relevant entries in my KeyChain (in the hope SS would pop a login dialog - but it didn’t).
  • Made sure the Mac Mini is awake.
  • Checked logs but can find nothing at all on Screen Sharing.
  • Installed the ARD update on both machines.
  • Checked Firewall settings - Screen sharing is specifically allowed (and there are no other sharing functions blocked).
Nothing has worked.

The iMac is connected to the router by cable; the Mac Mini is connected by wifi.

Screen sharing worked under 10.10 and 10.10.1. Now it doesn't. I haven't played with settings except as stated above.

Does anyone have any ideas ? This has me totally stumped.

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.