Samba Mounts on Yosemite

Joined
Jun 22, 2007
Messages
347
Reaction score
2
Points
18
Your Mac's Specs
iMac (27 inch, Late 2012), Processor: Core i5, Memory: 16GB 1333 Mhz DDR3 running MacOS Catalina
While using Mavericks, mounted the network samba shares from my linux file server. The reason for using samba is because I have windows systems on my network as well.

On Mavericks, they were working well. On Yosemite Developer Preview, they worked well. But after Yosemite was released, I did a clean install. Now it seems that every time I try to copy a file or a folder to the shared drives, the computer just restarts like someone pressed the hard reset button. Any ideas?
 

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
14,242
Reaction score
913
Points
113
Location
MA
Your Mac's Specs
2022 Mac Studio, macOS Monterrey, 32 GB
I have a couple of VMs on my rMBP running Yosemite. One is a Linux VM sharing a folder over SAMBA. The other VM is a Windows 8 VM that mounts that share and I've got it mounted on the OS X side and am reading/writing lots of data without any problems..
 
Joined
Jun 22, 2007
Messages
347
Reaction score
2
Points
18
Your Mac's Specs
iMac (27 inch, Late 2012), Processor: Core i5, Memory: 16GB 1333 Mhz DDR3 running MacOS Catalina
Could it be my network drivers?
 
Joined
Oct 28, 2014
Messages
1
Reaction score
0
Points
1
We were having the same issues at the office with our Debian 7.6 virtual machines. The issue seems to be related to the SMB3 protocol.

Here's the fix:

SMB2 support in 3.6.0 is fully functional (with one omission), and can be enabled by setting:

max protocol = SMB2

in the [global] section of your smb.conf and re-starting Samba.
 
Joined
Oct 31, 2014
Messages
1
Reaction score
0
Points
1
Thank you!

We were having the same issues at the office with our Debian 7.6 virtual machines. The issue seems to be related to the SMB3 protocol.

Here's the fix:

SMB2 support in 3.6.0 is fully functional (with one omission), and can be enabled by setting:

max protocol = SMB2

in the [global] section of your smb.conf and re-starting Samba.

I was getting frequent random freezes while using SMB shares from my VMware Ubuntu server on Yosemite 10.10 (14A389) until I set the max protocol as you suggested. Thank you thank you!
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top