Removing unwanted network addresses

Joined
Jun 18, 2010
Messages
27
Reaction score
0
Points
1
Please could someone tell me how to remove old network addresses from the dropdown menu under the Airport icon? Thanks
 
OP
W
Joined
Jun 18, 2010
Messages
27
Reaction score
0
Points
1
I have removed all the unwanted addresses from the Preferred Networks box in the System preferences>Network>Airport>Advanced page, unchecked Remember Networks and rebooted but they all still come up under the Airport when I click on Join Other Network. I have to do this to re-establish a connection. I have changed my ISP to try and improve the connectivity which is intermittent.
 
OP
W
Joined
Jun 18, 2010
Messages
27
Reaction score
0
Points
1
I realise now the Airport list is showing available networks in the area, but there is one dominant one that my computer keeps flipping to and then disconnecting. It has come back into the Preferred Networks box mentioned above. Can I block that particular one somehow?
 

cwa107


Retired Staff
Joined
Dec 20, 2006
Messages
27,042
Reaction score
812
Points
113
Location
Lake Mary, Florida
Your Mac's Specs
14" MacBook Pro M1 Pro, 16GB RAM, 1TB SSD
I realise now the Airport list is showing available networks in the area, but there is one dominant one that my computer keeps flipping to and then disconnecting. It has come back into the Preferred Networks box mentioned above. Can I block that particular one somehow?

It shouldn't attempt to connect to anything that you yourself haven't previously tried connecting to. I believe you said you've already done this, but the procedure to remove an unwanted (previously connected to) WiFi connection is to go to:

1. Apple Menu => System Preferences
2. Network
3. Select AirPort (or Wi-Fi if you have 10.7) from the left window pane
4. Click 'Advanced' button in the right window pane
5. Select the AirPort (or "Wi-Fi") tab. This should show any previously connected-to network. Select the network and click "-" to remove it.
6. Click OK
7. Click Apply
8. Close the window.

If this truly is what you've already done, I would also recommend changing your wireless router's "channel" setting to something else as the offending network may just be sending out a more "palatable" signal (although it really shouldn't be trying to connect to it without your say-so). Also, be sure you're using WPA security (not WEP) and have SSID broadcast ENABLED.
 
OP
W
Joined
Jun 18, 2010
Messages
27
Reaction score
0
Points
1
Hi Staff. Thank you for that information. I have already performed the actions (1-8) you describe, so I will contact the new ISP and check the other details you mention. Where do I see whether SSID broadcast is enabled?
 

cwa107


Retired Staff
Joined
Dec 20, 2006
Messages
27,042
Reaction score
812
Points
113
Location
Lake Mary, Florida
Your Mac's Specs
14" MacBook Pro M1 Pro, 16GB RAM, 1TB SSD
The settings I'm referring to are configured within your wireless router's setup program (typically configured via a webpage). You'll need to consult the documentation that came with your router to determine how to access it. I can't give you specifics because they vary (widely) from router to router. If it was supplied by your ISP (i.e. you didn't purchase a wireless router, it was given to you when your service was installed), then you'll want to check with your ISP.
 
OP
W
Joined
Jun 18, 2010
Messages
27
Reaction score
0
Points
1
I've had a long chat woith the ISP who have identified a point in the Airport settings where the problem might occur. If I follow your instructions 1-3 as above
1. Apple Menu => System Preferences
2. Network
3. Select AirPort (or Wi-Fi if you have 10.7) from the left window pane
I see a Location box that is selected as "Automatic". It has a dropdown menu that also offers "macbook"
With that Location box showing Automatic, there is also another box called "Network Name" which shows your Business Hub. That box also has a dropdown menu with three other network addresses that I want to remove. I have already removed those addresses from the Preferred Networks box. How can I remove them from the Network Name box, please?
 

cwa107


Retired Staff
Joined
Dec 20, 2006
Messages
27,042
Reaction score
812
Points
113
Location
Lake Mary, Florida
Your Mac's Specs
14" MacBook Pro M1 Pro, 16GB RAM, 1TB SSD
When you click the drop down that currently reads "Automatic", there should be an option to 'Edit Locations'. From there, you can remove the miscellaneous locations.
 
OP
W
Joined
Jun 18, 2010
Messages
27
Reaction score
0
Points
1
Thank you cwa107 - but doesn't that "Edit Locations" box only allow me to remove either "Automatic" or "macbook"? I need to get at the network addresses that come up when I click on Automatic, because I do need to use the Automatic option - but only with my one preferred network.
 
OP
W
Joined
Jun 18, 2010
Messages
27
Reaction score
0
Points
1
I am still hoping for help with the problem I posted at 3:41 on 12.12.11. The problem seems to show on the page where I can "Edit Locations" on my Airport settings between Automatic and macbook, but I have not received any advice on how to remove the Network addresses that appear in the dropdown menu of networks on that page.
Also, despite clearing and restarting I notice macforums is not showing any threads since 12th (today is 14th) and I seem to be the only person looking at the threads. Is it a holiday where you are, or is there also a problem with my pages updating?
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,247
Reaction score
1,834
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
Please do not start a new thread. If you wish to "bump" your old thread to the top of the list of threads, just reply to it with the word "bump". Starting a new thread will only cause confusion and you'll wind up with replies that are scattered about.
 
OP
W
Joined
Jun 18, 2010
Messages
27
Reaction score
0
Points
1
Please can you help with this - or else let me know if there is no remedy or if you need more info. It is really causing me a problem. Thanks
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top