Problem with Internet connection

Joined
Jan 24, 2014
Messages
11
Reaction score
0
Points
1
For the last month or so I’ve been intermittently, but with increasing frequency, unable to load pages or get my e-mail working. The thing is that the connection does not actually drop, but my browsers and my e-mail cannot connect to the servers, or they do but after a very long time.

After doing all the troubleshooting I could think of (shutting down and restarting both modem and router countless times, deleting all the caches on my system, deleting the Configuration folder, changing the DNS numbers several times, repairing permissions, running Disk Warrior), I finally, I talked to a Fios technician. He told me that my Default TCP Receive Window (RWIN) should be 1045440, but it is 359104.
According to him, the problem is on the mac side. I called AppleCare and they recommended that I reinstall my system (10.9.5). Which I did.

The problem still happens randomly, and when I go the page http://www.speedguide.net/analyzer.php, to check the RWIN number I see that is still 350104.

At this point, I no longer know what to do. Does anyone out there know how to change this RWIN number?
 

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
14,510
Reaction score
1,072
Points
113
Location
MA
Your Mac's Specs
2022 Mac Studio, macOS Monterrey, 32 GB
I'm on a rMBP right now at work through a Comcast connection and that website reports my RWIN to be 131760 and I haven't had any issues with drops or disconnects or anything..

I will check my numbers at home on my iMac and my wife's Macbook Air and report back since I also have FiOS at home..
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top