• Welcome to the new Mac-Forums. See News and Community Announcements for more details.

Powered USB Hub turning off/losing power?

Joined
Sep 6, 2008
Messages
836
Reaction score
0
Points
16
Your Mac's Specs
13" MBP - 2.7 Ghz, Intel Core i7, 8GB RAM.
I have this powered USB hub going into my iMac with only 3 external drives connected to it. The hub seems to be losing power and turning off at random times - why would this be if it’s powered?
 
Joined
May 21, 2012
Messages
7,834
Reaction score
141
Points
63
Location
13th state, U.S.A.
Your Mac's Specs
iPhone 11 iOS 13, 12.9" iPad Pro 1 iPadOS 13, Late 2014 Mac Mini macOS 10.15
What is the power cord plugged into? Also, it could be a loose cord connection, either at the plug end, or the input into the hub.

When this happens, do all the drives become disconnected?
 
Joined
Sep 6, 2008
Messages
836
Reaction score
0
Points
16
Your Mac's Specs
13" MBP - 2.7 Ghz, Intel Core i7, 8GB RAM.
It’s plugged into a power strip (perhaps needs its own socket?).
When it happens, all drives get disconnected.
 
Joined
Aug 28, 2017
Messages
290
Reaction score
4
Points
18
Location
Wales, UK
Your Mac's Specs
iMac 27" 32GB i7 2TB OSX 10.15.5 late 2013
the problem here could be that the drives are drawing too much current what's the rating of the USB hub ?

and is it while accessing one drive or two or three at the same time ?
 
Joined
May 21, 2012
Messages
7,834
Reaction score
141
Points
63
Location
13th state, U.S.A.
Your Mac's Specs
iPhone 11 iOS 13, 12.9" iPad Pro 1 iPadOS 13, Late 2014 Mac Mini macOS 10.15
Some green (smart) power strips have outlets that turn off power to them, if devices go into standby mode.
 
Joined
Aug 28, 2017
Messages
290
Reaction score
4
Points
18
Location
Wales, UK
Your Mac's Specs
iMac 27" 32GB i7 2TB OSX 10.15.5 late 2013
now see Ferrarr I didn't think of that lol,

im glad one of us on the ball.
 
Top