Permissions more pickled than a Korean pizza

Joined
Aug 18, 2008
Messages
6
Reaction score
0
Points
1
System : New 10.5 Leopard imac and wireless keyboard/mouse.

Hi helpful people,

I'm in a pickle. My weeks-old imac has gone belly up. I'm pretty adept with a PC, so I feel a little stupid at what has happened as it was my fault. But at the same time I'm a little angry that it was so easy to do.

Long story short, my imac will now not go past a gray screen. No Command keys are working either.

I was trying to set up File Sharing so my mates could download from my external hard drive. This was easy and intuitive for afp, but when I tried to get smb or ftp going for my Windows buddies it was very hard to do - the only way I could get it to work was to make them a full user, not a sharing-only user (that took me a long time to work out). Strange. Anyway, when they logged on they could see every file on all my hard disks even if they couldn't download them. I didn't really want them to see "Deirdre bangs Dallas XVI.avi" so I went about changing permissions on my hard disks.

Guess what, it turns out the user group "Everyone" means "Everyone including the other users", not "Everyone excluding the other users".

So I set Everyone to "No Access" and denied my computer access to its hard drive. All it took was a couple of clicks of the mouse. Wonderful. Could have been done by accident. Beats me why it is so easy to do. I don't remember any warning bells or flashing lights.

The computer locked up and wouldn't boot past the gray screen.

I could not access any Command keys on boot (maybe because I had a wireless keyboard?)

Using the Apple Remote menu button I managed to boot my Install CD. I ran Disk Utility and all it replied for both verify and repair was:

"Error: The underlying task reported failure on exit"

So I looked on the internet and found this post. The author said I wasn't the only idiot to have done this, and first to type "chmod -R 777 /" into
Single User Mode. But because my comp would not boot into Single User Mode I figured the Terminal would have to do (DOS is DOS right?).

That did something, lots of lines of text appeared in the Terminal window. I then tried to type the rest of what was suggested and I got not no response from any of them, just a new prompt (fsck -y and mount -uw /).

Disk Utility still reported the same error message.

Desperate, I wanted to get into Single User Mode, so I typed the following into the Terminal: # nvram boot-args="-s" and then # reboot.

That really did it. Now I have a gray screen and can't do anything except boot off the Install Disk, which also now hangs on a gray screen.

So I paid for a USB keyboard to try and get into Single User Mode to repair the damage, and I still can't use any Command keys on startup.

Sigh.

... And now for the horrible sting in the tail: I live in Korea, and speak limited Korean. And Koreans, bless their souls, don't tend to speak much English. So I've resigned myself to a four-hour trip to the Seoul Apple service center on Saturday and using sign language like a monkey.

Don't bother giving me any solutions to this mess, short of hitting the booze; I'm going to let the service center sort it out. My guess is they will tell me I've lost it all and hope I've got a backup.

So what I would like to know is: Do I have any chance to get my files back off the Macintosh HD?

I give you full permission to laugh at my misery.


*** Korean pizzas always come with pickles. Very very strange. ***
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
65,248
Reaction score
1,831
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 8, iPhone 11, iPhone 12 Mini, Numerous iPods, Monterey
You've done a splendid job of "shooting yourself in the foot". :Smirk:

All kidding aside, I think you'll find the nice folks at the Seoul Apple store more than willing to help. As far as English goes, I spent quite a bit of time in Seoul and found most Koreans speak fairly good English. You should have no difficulty communicating with them.

As far as getting your files off the HD, the technicians at the Apple store should be able to do that using target disk mode. If not, you'll have to start over.

And, why in the world did you want to share your files that way? Not a very wise decision letting your friends have access to the hard drive. :(

Let us know how you make out.

Regards.
 
OP
S
Joined
Aug 18, 2008
Messages
6
Reaction score
0
Points
1
problem fixed

Fixed :)

Okay, here's how it went...

I took it in to the nearest service center to be fixed, and if I understand the guy (he couldn't speak any English) there was a short on the motherboard and he replaced it.

He managed to get my files back using target disk mode, then he reformatted and reinstalled.

It was all covered under warranty.

However, I have my suspicions about whether the motherboard was actually bung, because it is one big coincidence that it would go down at the same time as I changed the permissions... (Maybe the number of times I unplugged and replugged the power cord trying to get it to work did that?)

So after a week of getting my comp the way I like it... I'm all happy.

Cheer cheer
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top