OSX SCSI & scanner recognition problems



I've had a problem getting my G3 with OSX (10.3) to see my old UMAX 1200s scanner. Under OS9 I didn't have this problem. After some exploration, it seems that UMAX doesn't support their products well, and it would seem the only way to use this scanner would be to puchase some Silverfast software or boot into OS9.2.2 and scan from there. Being cheap and needing to use the scanner right away, I decided to use the OS9.2.2 method, but I still get the same problem.

The error message reads:

Scanner not found or not ready.
(Check cable connections, SCSI id.
Restart the scanner & redo scanning.)

Well, I have repeatedly checked the cable connections and SCSI id. I have tried id's 4-6 with no success. The SCSI card drivers are installed (Adaptec 290X-2930 v.1.1.0, loaded, valid, authentic, & satisfied under system profile), but the system profile finds no information on SCSI devices. The UMAX VistaScan/twain have all been installed. I have seen mention of termination problems with SCSI devices, but considering the fact that the scanner worked fine all by itself in OS9, I don't think that termination is the problem. It is possible that the SCSI card decided to go bad the day I switched to OSX, but that too would seem to be an improbable scenario. Any help would be much appreciated.

comp specs:

blue & white G3
300 MHZ
256 MB RAM

OSX (10.3)
updated OS 9.2.2

UMAX Astra 1200S scanner (only SCSI device)
Adaptec SCSI 2906
DB25 SCSI connector

- Thanks,
- Brien.OSX SCSI & scanner recognition problems

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.