OS X 10.7.5 Kernel Panics

Dec 28, 2014
Reaction score
I'm not very experienced with using Macs, so please bear with me. I'm attempting to fix my girlfriend's MacBook Pro currently, after it has restarted on her several times (coming up with a kernel panic log afterwards).

The following log is basically the same as all the rest of them, with some small changes (such as moving from CPU 4 to 6).

panic(cpu 4 caller 0xffffff80002c4794): Kernel trap at 0x0000000000000018, type 14=page fault, registers:
CR0: 0x0000000080010033, CR2: 0x0000000000000018, CR3: 0x000000013d3ac048, CR4: 0x00000000001606e0
RAX: 0xffffff800c0b0680, RBX: 0x0000000000000000, RCX: 0xffffff800b6db3c0, RDX: 0xffffff800c17c808
RSP: 0xffffff808063b8e8, RBP: 0xffffff808063ba20, RSI: 0x00ffffff800dff7b, RDI: 0xffffff800c0b0680
R8: 0x0000000000000000, R9: 0xffffff800c17c800, R10: 0xfffffe8157397600, R11: 0x000000000012c037
R12: 0xffffff806b6f5000, R13: 0xffffff806b6f5000, R14: 0x0000000000000000, R15: 0xffffff800c17c800
RFL: 0x0000000000010282, RIP: 0x0000000000000018, CS: 0x0000000000000008, SS: 0x0000000000000000
CR2: 0x0000000000000018, Error code: 0x0000000000000010, Faulting CPU: 0x4

Backtrace (CPU 4), Frame : Return Address
0xffffff808063b590 : 0xffffff8000220792
0xffffff808063b610 : 0xffffff80002c4794
0xffffff808063b7c0 : 0xffffff80002da55d
0xffffff808063b7e0 : 0x18
0xffffff808063ba20 : 0xffffff7f81ea70e9
0xffffff808063ba30 : 0xffffff7f81e7db11
0xffffff808063ba40 : 0xffffff7f81e529f5
0xffffff808063ba90 : 0xffffff7f81e52e91
0xffffff808063bad0 : 0xffffff7f81e4f6d4
0xffffff808063bb00 : 0xffffff7f81e4f981
0xffffff808063bb20 : 0xffffff7f8187e062
0xffffff808063bb40 : 0xffffff7f8187e384
0xffffff808063bb70 : 0xffffff7f81e6e4f1
0xffffff808063bba0 : 0xffffff7f81e519db
0xffffff808063bbf0 : 0xffffff7f81e6f307
0xffffff808063bc20 : 0xffffff7f81eaef4b
0xffffff808063bc40 : 0xffffff7f81e5a607
0xffffff808063bc70 : 0xffffff7f81ea0103
0xffffff808063bca0 : 0xffffff7f81e57cca
0xffffff808063bcc0 : 0xffffff8000657c37
0xffffff808063bce0 : 0xffffff800029c122
0xffffff808063bd30 : 0xffffff80002230b5
0xffffff808063bd60 : 0xffffff80002148a9
0xffffff808063bdc0 : 0xffffff8000223223
0xffffff808063bde0 : 0xffffff80002516f9
0xffffff808063be20 : 0xffffff80002199ae
0xffffff808063be70 : 0xffffff800021a1fd
0xffffff808063beb0 : 0xffffff80002378f0
0xffffff808063bef0 : 0xffffff8000544d49
0xffffff808063bf40 : 0xffffff800054288e
0xffffff808063bf50 : 0xffffff80005ce4cb
0xffffff808063bfb0 : 0xffffff80002daea3
Kernel Extensions in backtrace:
dependency: com.apple.NVDAResman(7.3.2)[97284661-2629-379E-B86B-D388618E8C30]@0xffffff7f808ff000
dependency: com.apple.iokit.IONDRVSupport(2.3.4)[7C8672C4-8B0D-3CCF-A79A-23C62E90F895]@0xffffff7f808ed000
dependency: com.apple.iokit.IOPCIFamily(2.7)[5C23D598-58B2-3204-BC03-BC3C0F00BD32]@0xffffff7f80889000
dependency: com.apple.iokit.IOGraphicsFamily(2.3.4)[D0A1F6BD-E66E-3DD8-9913-A3AB8746F422]@0xffffff7f808b4000

BSD process name corresponding to current thread: WebProcess

Mac OS version:

Kernel version:
Darwin Kernel Version 11.4.2: Thu Aug 23 16:25:48 PDT 2012; root:xnu-1699.32.7~1/RELEASE_X86_64
Kernel UUID: FF3BB088-60A4-349C-92EA-CA649C698CE5
System model name: MacBookPro9,1 (Mac-4B7AC7E43945597E)

System uptime in nanoseconds: 41840835558378
last loaded kext at 64321250443: com.apple.driver.AppleHWSensor 1.9.5d0 (addr 0xffffff7f82563000, size 28672)
last unloaded kext at 208591102154: com.apple.driver.AppleUSBTCKeyEventDriver 227.6 (addr 0xffffff7f82278000, size 8192)
loaded kexts:
com.apple.driver.AppleHWSensor 1.9.5d0
com.apple.driver.AppleMikeyHIDDriver 122
com.apple.driver.AGPM 100.12.75
com.apple.driver.X86PlatformShim 5.0.0d8
com.apple.driver.AppleHDA 2.2.5a5
com.apple.driver.AppleUpstreamUserClient 3.5.9
com.apple.driver.AppleMikeyDriver 2.2.5a5
com.apple.driver.AudioAUUC 1.59
com.apple.driver.AppleIntelHD4000Graphics 7.3.2
com.apple.driver.SMCMotionSensor 3.0.2d6
com.apple.driver.AppleSMCPDRC 5.0.0d8
com.apple.iokit.IOUserEthernet 1.0.0d1
com.apple.driver.AppleSMCLMU 2.0.1d2
com.apple.iokit.IOBluetoothSerialManager 4.0.8f17
com.apple.Dont_Steal_Mac_OS_X 7.0.0
com.apple.GeForce 7.3.2
com.apple.driver.AudioIPCDriver 1.2.3
com.apple.driver.ApplePolicyControl 3.1.33
com.apple.driver.AppleMuxControl 3.1.33
com.apple.driver.AppleLPC 1.6.0
com.apple.driver.AppleMCCSControl 1.0.33
com.apple.driver.AppleIntelFramebufferCapri 7.3.2
com.apple.filesystems.autofs 3.0
com.apple.driver.AppleUSBTCButtons 227.6
com.apple.driver.BroadcomUSBBluetoothHCIController 4.0.8f17
com.apple.driver.AppleUSBTCKeyboard 227.6
com.apple.driver.AppleIRController 312
com.apple.AppleFSCompression.AppleFSCompressionTypeDataless 1.0.0d1
com.apple.AppleFSCompression.AppleFSCompressionTypeZlib 1.0.0d1
com.apple.BootCache 33
com.apple.iokit.SCSITaskUserClient 3.2.1
com.apple.driver.XsanFilter 404
com.apple.iokit.IOAHCISerialATAPI 2.0.3
com.apple.iokit.IOAHCIBlockStorage 2.1.0
com.apple.driver.AppleFWOHCI 4.9.0
com.apple.driver.AppleSDXC 1.2.2
com.apple.iokit.AppleBCM5701Ethernet 3.2.4b8
com.apple.driver.AppleUSBHub 5.1.0
com.apple.driver.AppleEFINVRAM 1.6.1
com.apple.driver.AppleSmartBatteryManager 161.0.0
com.apple.driver.AirPort.Brcm4331 561.7.22
com.apple.driver.AppleAHCIPort 2.3.1
com.apple.driver.AppleUSBEHCI 5.1.0
com.apple.driver.AppleUSBXHCI 1.1.0
com.apple.driver.AppleACPIButtons 1.5
com.apple.driver.AppleRTC 1.5
com.apple.driver.AppleHPET 1.7
com.apple.driver.AppleSMBIOS 1.9
com.apple.driver.AppleACPIEC 1.5
com.apple.driver.AppleAPIC 1.6
com.apple.driver.AppleIntelCPUPowerManagementClient 195.0.0
com.apple.nke.applicationfirewall 3.2.30
com.apple.security.quarantine 1.4
com.apple.security.TMSafetyNet 8
com.apple.driver.AppleIntelCPUPowerManagement 195.0.0
com.apple.driver.DspFuncLib 2.2.5a5
com.apple.iokit.IOSurface 80.0.2
com.apple.iokit.IOFireWireIP 2.2.5
com.apple.iokit.IOSerialFamily 10.0.5
com.apple.iokit.IOAudioFamily 1.8.6fc18
com.apple.kext.OSvKernDSPLib 1.3
com.apple.driver.AppleHDAController 2.2.5a5
com.apple.iokit.IOHDAFamily 2.2.5a5
com.apple.driver.AppleSMBusPCI 1.0.10d0
com.apple.driver.AppleGraphicsControl 3.1.33
com.apple.driver.X86PlatformPlugin 5.1.1d6
com.apple.driver.AppleSMC 3.1.3d10
com.apple.driver.IOPlatformPluginFamily 5.1.1d6
com.apple.driver.AppleBacklightExpert 1.0.4
com.apple.nvidia.nvGK100hal 7.3.2
com.apple.driver.AppleSMBusController 1.0.10d0
com.apple.NVDAResman 7.3.2
com.apple.iokit.IONDRVSupport 2.3.4
com.apple.iokit.IOGraphicsFamily 2.3.4
com.apple.kext.triggers 1.0
com.apple.driver.AppleUSBBluetoothHCIController 4.0.8f17
com.apple.iokit.IOBluetoothFamily 4.0.8f17
com.apple.driver.AppleUSBMultitouch 230.5
com.apple.iokit.IOUSBHIDDriver 5.0.0
com.apple.driver.AppleThunderboltDPInAdapter 1.8.5
com.apple.driver.AppleThunderboltDPAdapterFamily 1.8.5
com.apple.driver.AppleThunderboltPCIDownAdapter 1.2.5
com.apple.driver.AppleUSBMergeNub 5.1.0
com.apple.driver.AppleUSBComposite 5.0.0
com.apple.iokit.IOSCSIMultimediaCommandsDevice 3.2.1
com.apple.iokit.IOBDStorageFamily 1.7
com.apple.iokit.IODVDStorageFamily 1.7.1
com.apple.iokit.IOCDStorageFamily 1.7.1
com.apple.driver.AppleThunderboltNHI 1.6.0
com.apple.iokit.IOThunderboltFamily 2.0.3
com.apple.iokit.IOSCSIArchitectureModelFamily 3.2.1
com.apple.iokit.IOFireWireFamily 4.4.8
com.apple.iokit.IOEthernetAVBController 1.0.1b1
com.apple.iokit.IOUSBUserClient 5.0.0
com.apple.iokit.IO80211Family 420.3
com.apple.iokit.IONetworkingFamily 2.1
com.apple.iokit.IOAHCIFamily 2.0.8
com.apple.iokit.IOUSBFamily 5.1.0
com.apple.driver.AppleEFIRuntime 1.6.1
com.apple.iokit.IOHIDFamily 1.7.1
com.apple.iokit.IOSMBusFamily 1.1
com.apple.security.sandbox 177.11
com.apple.kext.AppleMatch 1.0.0d1
com.apple.driver.DiskImages 331.7
com.apple.iokit.IOStorageFamily 1.7.2
com.apple.driver.AppleKeyStore 28.18
com.apple.driver.AppleACPIPlatform 1.5
com.apple.iokit.IOPCIFamily 2.7
com.apple.iokit.IOACPIFamily 1.4
Model: MacBookPro9,1, BootROM MBP91.00D3.B08, 4 processors, Intel Core i7, 2.3 GHz, 4 GB, SMC 2.1f175
Graphics: NVIDIA GeForce GT 650M, NVIDIA GeForce GT 650M, PCIe, 512 MB
Graphics: Intel HD Graphics 4000, Intel HD Graphics 4000, Built-In, 384 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1600 MHz, 0x80CE, 0x4D34373142353737334448302D434B302020
Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1600 MHz, 0x80CE, 0x4D34373142353737334448302D434B302020
AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (
Bluetooth: Version 4.0.8f17, 2 service, 18 devices, 1 incoming serial ports
Network Service: Wi-Fi, AirPort, en1
Serial ATA Device: APPLE HDD HTS547550A9E384, 500.11 GB
Serial ATA Device: HL-DT-ST DVDRW GS31N
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1a100000 / 2
USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0x1a110000 / 3
USB Device: hub_device, 0x8087 (Intel Corporation), 0x0024, 0x1d100000 / 2
USB Device: hub_device, 0x0424 (SMSC), 0x2513, 0x1d180000 / 3
USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0252, 0x1d183000 / 6
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0x1d182000 / 5
USB Device: BRCM20702 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0x1d181000 / 4
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821d, 0x1d181300 / 9

From what I understand, this narrows it down to the nVidia GPU. I ran the AHT and it found no problems (even with extensive testing), and I ran disk utility which also found no problems, so I'm thinking it must be software related.

Am I correct in my assumptions? What is the best way to fix this issue? I'll do my best to respond to any question ASAP.

edit: I just wanted to add that this issue seems to be totally random... she mentioned that she always had Microsoft Word open when it happened, but I believe that she always has Microsoft Word open.
Last edited:
Jul 24, 2013
Reaction score
Ohio (USA)
Your Mac's Specs
2023-14" M3max MBPro, 64GB/1TB, iPhone 15 Pro, Watch Ultra
I hope some others more experienced weigh in on this but in my opinion it does not look like a GPU issue. In fact it looks more like a logic board issue. But I could be wrong. Hopefully some of the others will take a look and offer an opinion.



Well-known member
Staff member
May 20, 2008
Reaction score
Your Mac's Specs
2017 15" MBP, 16gig ram, 1TB SSD, OS 10.15
What you want to figure out is…do you have a software or hardware problem. The easiest way to see if it's a software problem is…boot the computer from an external HD with only a fresh install of the OS on it (nothing else). Then check for stability.

If this passes the stability test then you probably have a hardware issue. With a MacBook Pro…the only hardware things you can do anything about is change the HD or replace the ram (bad ram is a frequent kernel panic source). If the computer has a bad logic board or graphics hardware…the solution is a replacement logic board. Which in many cases…is too expensive to be a worthwhile repair to pursue.

- Nick

p.s. You also should not have anything connected to the computer (printers, dongles, etc.)…except for the external HD I mentioned above for testing proposes.

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.