• Welcome to the new Mac-Forums. See News and Community Announcements for more details.

No Texts on iPad

Joined
Aug 31, 2009
Messages
107
Reaction score
0
Points
16
I get text messages to and from my iPhone. It has my phone number. But, my iPad just has my email address and I've tried to change it to my phone number but there doesn't seem to be a way. So, my text messages won't sync to both devices. Help please. Thanks.
 
Joined
May 21, 2012
Messages
7,818
Reaction score
139
Points
63
Location
13th state, U.S.A.
Your Mac's Specs
Late 2014 Mac Mini macOS 10.15, iPhone 11 iOS 13, 12.9" iPad Pro 1 iPadOS 13
On the iPhone, make sure you have enabled text forwarding.
 
Joined
Jul 24, 2013
Messages
4,246
Reaction score
202
Points
63
Location
Ohio (USA)
Your Mac's Specs
2020 13" MBPro, 2010 MacPro, 11”‘ iPad Pro, iPhone Xs Max
On your iPad go to Settings -> Tap on your name on the left (Apple ID). Then look at Reachable at. It should show your iPhone number and under it list iMessage and Face time. If that is wrong you can can tap on edit or add a phone number if necessary to receive iMessages.

Here is a link from Apple with more information. Scroll down to find the part about iMessage problems.

If you can'''t send or receive messages on your iPhone, iPad, or iPod touch - Apple Support

Lisa
 

Raz0rEdge

Well-known member
Staff member
Moderator
Joined
Jul 17, 2009
Messages
12,661
Reaction score
304
Points
83
Location
MA
Your Mac's Specs
2018 Mac-Mini macOS Catalina 10.15.5, 32 GB
Go to Settings->Messages and click on Send & Receive and there you will see a list of all the ways people can reach you (phone and email) and how your messages go out. Ensure that your number is listed as an accessible thing and not just your email.
 
Joined
Aug 31, 2009
Messages
107
Reaction score
0
Points
16
Not working

Go to Settings->Messages and click on Send & Receive and there you will see a list of all the ways people can reach you (phone and email) and how your messages go out. Ensure that your number is listed as an accessible thing and not just your email.
I did as you suggested, but all that's there is my email address and no way to add a phone number. When I click on my Apple I.D. above all this, it gives me three options, Change location, Sign Out and Cancel. I tried the sign out option the other day and it caused all kinds of problems. I almost couldn't get back in. In fact I had to reset my iPad completely.
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,432
Reaction score
755
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
Have you tried what Lisa suggested in reply #3? That should work.
 
Joined
Aug 31, 2009
Messages
107
Reaction score
0
Points
16
On your iPad go to Settings -> Tap on your name on the left (Apple ID). Then look at Reachable at. It should show your iPhone number and under it list iMessage and Face time. If that is wrong you can can tap on edit or add a phone number if necessary to receive iMessages.

Here is a link from Apple with more information. Scroll down to find the part about iMessage problems.

If you can'''t send or receive messages on your iPhone, iPad, or iPod touch - Apple Support

Lisa
Lisa, I did as you suggested, and there are three items there. My email, my iPhone phone number and my iCloud email address. My number is correct, so I don't know what's up with that. I used to get my text message on my iPad, but not anymore. I completely reset my iPad, but to know avail.

- - - Updated - - -

Yes, but it didn't work. See my response to her. Thanks chscag.
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,432
Reaction score
755
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
Yes, but it didn't work. See my response to her. Thanks chscag.
Okay. Have you tried signing out of iCloud on all your devices and then signing back in? I see that you stated above that you signed out of your Apple ID but I'm not sure exactly what it was that you did? Signing in and out of iCloud should be easy and not cause you any problems.
 
Joined
Aug 2, 2011
Messages
1,720
Reaction score
56
Points
48
Location
Tyneside, UK
Your Mac's Specs
MBP Retina mid 2015 15.4" 16GB 2.5 GHz OS Catalina; iPhone 7 128gb; iPad Mini 2, 32gb
Are messages enabled under Settings > iCloud> Messages on both devices?
 
Joined
May 21, 2012
Messages
7,818
Reaction score
139
Points
63
Location
13th state, U.S.A.
Your Mac's Specs
Late 2014 Mac Mini macOS 10.15, iPhone 11 iOS 13, 12.9" iPad Pro 1 iPadOS 13
All I show is “call forwarding”. No text forwarding.
Did you look in Settings > Messages? I have the option of "Text message Forwarding" for my 2 other devices (iPad and Mini).
 
Joined
May 21, 2012
Messages
7,818
Reaction score
139
Points
63
Location
13th state, U.S.A.
Your Mac's Specs
Late 2014 Mac Mini macOS 10.15, iPhone 11 iOS 13, 12.9" iPad Pro 1 iPadOS 13
The Settings I am referring to are on the iPhone, not the iPad.
 
Top