Make/Xcode problems

Oct 5, 2014
Reaction score

I'll be the first to admit I'm not a programmer and this is why this has me stumped. I'm trying to compile the latest source of a program (Seventh Sense - Lone Wolf: A book player) since the current Mac build is a full version old but I've run into a brick wall. First I tried using Xcode, I worked out how to import things and then had to start extracting the contents of the libs folder and adding them to the Xcode project. It went from errors about unable to find something like SDL.h to telling me that it couldn't find <sdl.h> and to use quotes instead. I did that and then it started spitting out semantic errors.

Discarding the Xcode idea I tried to do what I should have done at first and use make. I had to once again copy the library files into the src directory because it wasn't finding them where they were and then I got the angled bracket error again. Had to go through fixing them and them it spat out a "Clang error: Linker command failed with exit code 1" albeit with slightly different punctuation. I don't have it up in front of me I'm afraid.

A bit of research has told me that it couldn't find the files in <>s because it didn't know where to look but I'm honestly stumped at this point. I copied them in, changed the references to use direct ""s instead and it still won't make. I'm sure it's something simple that I'm just overlooking but I'd be grateful for any help.


Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.