Leopard and FastTrack Pro

Jul 5, 2008
Reaction score
I have a three month old MacPro, trying to use an M-Audio FastTrackPro USB device. The issue is that I get this very loud digital sound that occurs randomly, and always at start up. The entire room vibrates like it's about to explode. The only fix that stops my speakers from blowing is pulling out the USB connection, or sometimes, yanking all the inputs and outputs. M-Audio claims the device works up to 10.5.3, but I've tried 10.5.1, 10.5.2, 10.5.3 and 10.5.4 and the result is the same. I've swapped out all cables, nothing seems to work. M-Audio's support has been lame at best.
Assuming this product and drivers do work with the various Leopard versions (has anyone else had luck or problems?), is it possible for the problem to be related to the USB inputs on my Mac? (I've tried all the inputs and it's the same.) Is there some setting, some other trick I should try? Is there anyway to tell if the Mac is having issues?
I've got the latest driver. Any ideas would be greatly appreciated.

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.