iTunes podcast refresh button stopped working

Nov 5, 2009
Reaction score
Running iTunes 11.4(18)
OS X 10.8.5
MacBook Pro Retina, Mid 2012

I subscribe to maybe 10 or 12 podcasts, but I refresh the podcasts manually by clicking the refresh button. This has always worked nicely. Any newly available episodes have been found and downloaded when I click the refresh button.

Now, all of a sudden, the refresh button no longer does anything (other than rotate the arrow once). When I click on "Settings…", refresh is set to "Manually" but the "Last refresh" time is 3 days ago and does not change when I press the refresh button - and new podcast episodes are not even shown, let alone downloaded. I tried "refresh podcast" on each individual subscription - nothing. I manually unsubscribed/resubscribed to each podcast, which let me see the new episodes, but I had to download them manually.

I've restarted iTunes and even rebooted my computer. Podcast refresh is still broken. I have no idea why.

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.