iTunes frustration

Joined
Feb 11, 2007
Messages
196
Reaction score
3
Points
18
Once I could find a tune in the library, double click on it and it would play. I miss that. Now it plays something else or just does nothing. I am sure iCloud works well for folks with a fast internet connection. but for the rest of us it has a way to go.
 
M

MacInWin

Guest
Hmmm, I do that all the time (Find a tune, double click and it plays). Not sure what iCloud has to do with it.
 

Slydude

Well-known member
Staff member
Moderator
Joined
Nov 15, 2009
Messages
17,214
Reaction score
827
Points
113
Location
North Louisiana, USA
Your Mac's Specs
M1 MacMini 16 GB - Ventura, iPhone 14 Pro Max, 2015 iMac 16 GB Monterey
Try the usual double click routine again. This time wait a little longer before trying another song. I'm noticing a bit of a lag with the current version of iTunes that I didn't notice before.

In my case it might be because I am accessing things over the network.
 
M

MacInWin

Guest
Well, I see no lag. My songs and videos are stored on an internal SSD, so the interface and read speeds are pretty fast. I suspect any lag is coming from network latency.
 

Slydude

Well-known member
Staff member
Moderator
Joined
Nov 15, 2009
Messages
17,214
Reaction score
827
Points
113
Location
North Louisiana, USA
Your Mac's Specs
M1 MacMini 16 GB - Ventura, iPhone 14 Pro Max, 2015 iMac 16 GB Monterey
I wondered the same thing but the lag seems to be a bit worse than it was under Mavericks. I haven't spent a lot of time trying to work this out yet.
 
OP
John F
Joined
Feb 11, 2007
Messages
196
Reaction score
3
Points
18
Using a 2010 MacAir on a slow connection shared with other users and lots of big pictures to upload to cloud services. This is not my primary computer so most of what I try to play has to come off the cloud.
 
M

MacInWin

Guest
Using a 2010 MacAir on a slow connection shared with other users and lots of big pictures to upload to cloud services. This is not my primary computer so most of what I try to play has to come off the cloud.

I also do what you are doing. And experience also the same bugs like yours.
Alice, and John, it's not a bug. It's just a competition for the limited bandwidth. Unless and until the bandwidth improves or competition eases, you're going to have slow play, interruptions and generally poor performance. Right now I am streaming music from the internet, watching a video stream as well and typing on this website. So it can be done, you just need big bandwidth.
 

Slydude

Well-known member
Staff member
Moderator
Joined
Nov 15, 2009
Messages
17,214
Reaction score
827
Points
113
Location
North Louisiana, USA
Your Mac's Specs
M1 MacMini 16 GB - Ventura, iPhone 14 Pro Max, 2015 iMac 16 GB Monterey
Update: i still have not spent time troubleshooting this but I have noticed the following behaviors recently.

1. The lag I am having is probably not a bug specific to iTunes. I ran Pandora day before yesterday for the first time since switching to Yosemite. If I push the play/pause button there is about a 1 second lag before anything happens.
2. The same problem occurs if I quit Safari with Pandora still open. There is almost a 1 second lag before the sound starts.
3. A similar lag occurs if I adjust the volume using up/down keys on the keyboard. This problem crosses all programs or at least seems so to me,. I don't think the same problem occurs if I adjust the volume using a headset.
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top