Ipod Touch App Update Issue (Itunes 8)

Sep 14, 2008
Reaction score
I'll tell the whole story so hopefully I can get some help. I got my ipod touch a week ago with my macbook. Everything has been going smoothly. I have about 10 apps on my ipod one is the AIM ap. I saw there was an update today, so I went to go update it, and after a minute I got this popup on my Ipod

"authorization failed. Please connect to Itunes"

So i connected to itunes, and pressed Retry and it said "can not retrieve download information. Please connect with Itunes" and the only choice to click is "dismiss"

I tried to update it from Itunes too and after it says "accessing Itunes store" and then "purchasing" for about a minute I get a pop up that says "Could not purchase "AIM". An Unknown error occured (-4)." And sometimes the error number is 5002.

I tried to download another Free app for messaging because I thought it was AIM and not anything else, so when I tried I got the same issue. an error that says "we could not complete your itunes store request. An unknown error has occured (-4)."

I saw some people were having my issue, but they saw this "black app" square and deleting it fixed their problem. Well I looked on my apps listed on my Ipod and Itunes and I didn't see that. I have tried to restart my computer, reinstall itunes and even tried to install an older itunes version but ended up redownloading Itunes 8.

I am pretty frustrated with this so if anyone knows how to fix it let me know

Shop Amazon

Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.