iPhoto headaches

Joined
May 1, 2012
Messages
23
Reaction score
0
Points
1
Version IPhoto 6 (6.0.6 (322))
Lost a larger number of photos, only thumbnails showing no actual picture.

So I've got exported copies on DVD/CD & a backup on external hard drive.

Been using backup to replace missing ones. Dates and times do not correspond to original so have been changing with copy/paste. After a long while doing this I noticed that the picture size on the backup is not always the same size as the original i.e. original size 2248 x 3264 3.0 MB backup 270 x 360 41 KB. Before I proceed what is happening here?
 
Joined
Apr 24, 2009
Messages
914
Reaction score
73
Points
28
Location
UK
Your Mac's Specs
Various Mac's
Have you tried any of the rebuild options?

It appears you have backed up the thumbnails, not the full size images. Control click your iPhoto library, then select show contents, can you see folders containing your original images?

A friend has terrible problems with here iPhoto library, but then hers is the biggest I've ever seen, she tells me its 480GB!
 
OP
E
Joined
May 1, 2012
Messages
23
Reaction score
0
Points
1
Attempted rebuild options first.

Thumbnails Ummm ... some photos on backup are full size others not. Some are in the same state as on iPhoto so must have been corrupted before last backup.

So if I delete iPhotos and copy originals back from CD/DVD's, is this the way to go?

Tried pressing Control on iPhoto ...nothing occurred.
 

IWT


Joined
Jan 23, 2009
Messages
8,839
Reaction score
1,090
Points
113
Location
Born Scotland. Worked all over UK. Live in Wales
Your Mac's Specs
iMac 5K Retina 27", August 2019, 3.6GHz Intel Core i9, Memory 32GB, 2TB SSD, macOS Monterey 12.5
Hi,

What Steve said is that the Ctrl-click is in relation to your iPhoto Library, not the iPhoto App which I think is what you were trying to do. Apologies if I've misunderstood you.

Ian
 
OP
E
Joined
May 1, 2012
Messages
23
Reaction score
0
Points
1
Took ages but managed to get everything back to the way it was...

Until today!

Before doing backup to DVD of latest batch of photos I checked previous DVD R used and noticed the exported title (where I always keep the number but add a name to photo) there was another issue.

The name on the title is not shown on the majority, but only on a few.

I also notice that the folder where photos are exported to is showing the same error, no name shown on majority of photos.

What is occurring? Is the operating system causing this? Baffled!
 
OP
E
Joined
May 1, 2012
Messages
23
Reaction score
0
Points
1
As a follow up to what occurred, I exported photos to DVD RW yesterday and the photos showed the titles including the name I attached.

i.e 372 Sunbathing Frogs.jpg

These names are OK on DVD, BUT...

The folder on iMac where I exported them to before burning them to DVD RW shows:-

IMG_372.jpg

Only 3 of the photos have retained their name out of approx. 400

Would be more than pleased if anyone has any ideas relating to what is occurring?
 

Shop Amazon


Shop for your Apple, Mac, iPhone and other computer products on Amazon.
We are a participant in the Amazon Services LLC Associates Program, an affiliate program designed to provide a means for us to earn fees by linking to Amazon and affiliated sites.
Top