• Welcome to the new Mac-Forums. See News and Community Announcements for more details.

iPhone 8S music not playing properly

Joined
Oct 18, 2009
Messages
56
Reaction score
1
Points
8
Location
South Carolina
Your Mac's Specs
2015 iMac running Mojave 10.14. 1TB Drive, 8 gigs RAM.
I have tons of songs synced to my iPhone from my iMac. I have always been able to open the music icon and play any song I want from my library while in my car or walking or similar. All of a sudden, only a couple of songs will play. the screen says I need to use WIFI or cellular data. What is going on now? Every time an update comes out, something happens. This is getting ridiculous.
 
Joined
Jul 6, 2008
Messages
784
Reaction score
30
Points
28
Is this music you purchased thru iTunes? Sounds like the songs are in the cloud and it's needing to download them to your phone to play them. But why it would have all of a sudden deleted all the local copies of the music from your phone, I have no idea. I'm using an iPhone SE (2020) with the latest updates and haven't experienced this. Maybe a sync setting in iTunes (or in Finder if you use Catalina) has been changed somehow?
 
Last edited:
Joined
Oct 18, 2009
Messages
56
Reaction score
1
Points
8
Location
South Carolina
Your Mac's Specs
2015 iMac running Mojave 10.14. 1TB Drive, 8 gigs RAM.
Is this music you purchased thru iTunes? Sounds like the songs are in the cloud and it's needing to download them to your phone to play them. But why it would have all of a sudden deleted all the local copies of the music from your phone, I have no idea. I'm using an iPhone SE (2020) with the latest updates and haven't experienced this. Maybe a sync setting in iTunes (or in Finder if you use Catalina) has been changed somehow?
Thanks usagora. It is baffling to me. I have very few songs purchased thru iTunes. The vast majority are from my vinyl albums that I've converted to mp3. Some came from Youtube and some downloaded from Frostwire (which doesn't exist anymore. Wish it did). After I posted this thread, I called Apple Support. I love that benefit from Apple. Anyway after trying a couple of things, he had me turn off/on the phone. Now it works as it's supposed to. No idea why.
 
Joined
Jul 6, 2008
Messages
784
Reaction score
30
Points
28
I have no idea either, but glad you found a solution. Hopefully it will work again if this issue reoccurs!
 
Top