• Welcome to the new Mac-Forums. See News and Community Announcements for more details.

iPhone 8 Speaker is default

Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
My wonderful, newly purchased 8 has lost it's mind. Whenever I make a phone call, it defaults to speaker. I turn the speaker off, it turns it back on. This can go on indefinitely, and I never win. I usually use earphones, and even with the earphone plugged in, the speaker is on. A menu pops up, I select 'iPhone' and the phone then proceeds to select speaker for itself. I tap the phone button, and we are back to speaker again. I'm on the latest iOS13. I've turned the phone and off, but it hasn't helped. Once again, any help will be greatly appreciated!
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,470
Reaction score
756
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
It appears from searching that the only thing that works is to reset the phone. I also have an iPhone 8 and generally keep the speaker on but I'm able to turn it off by tapping it.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
It appears from searching that the only thing that works is to reset the phone. I also have an iPhone 8 and generally keep the speaker on but I'm able to turn it off by tapping it.
ACK! As in wipe it and start all over again?
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,470
Reaction score
756
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
Yes, but make a backup first to iTunes. I know it sounds drastic, but it seems that's what works. I do not see anywhere in iOS 13.3.1, where it has a setting for keeping the phone speaker on or off. The only way that choice comes up is when you're on the phone during a call.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Thank you chsag. The phone is backed up, but I hope the photos on it are backed up too using iTunes?
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,470
Reaction score
756
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
I believe the photos will also be backed up but it's always best with photos and other valuable data to make sure you have an additional backup. I actually copy my valuable photos to DVDs in addition to backing them up on my iMac.
 

IWT


Joined
Jan 23, 2009
Messages
6,556
Reaction score
236
Points
63
Location
Born Scotland. Worked all over UK. Live in Wales
Your Mac's Specs
iMac 5K Retina 27", August 2019, 3.6GHz Intel Core i9, Memory 32GB, 2TB SSD, macOS Mojave 10.14.6
Thank you chsag. The phone is backed up, but I hope the photos on it are backed up too using iTunes?
The short answer is - Yes. Photos are backed up.

These two articles are confirmatory:

The Definitive Guide to iPhone Backup
Does backup in iTunes also backup picture… - Apple Community

If you import your pictures to the Photos app on a Mac, then it's a good idea to BU your Photos library to an External Hard Drive (EHD) as a bonus, as suggested by Admin chscag.

The Mac's Photos Library can be found by Opening Finder > Macintosh HD > Users > Your Name (House icon adjacent to it) > Pictures > Photos Library.photoslibrary (Then Copy/Paste to EHD)

Ian
 
Joined
Aug 2, 2011
Messages
1,724
Reaction score
58
Points
48
Location
Tyneside, UK
Your Mac's Specs
MBP Retina mid 2015 15.4" 16GB 2.5 GHz OS Catalina; iPhone 7 128gb; iPad Mini 2, 32gb
I believe the photos will also be backed up but it's always best with photos and other valuable data to make sure you have an additional backup. I actually copy my valuable photos to DVDs in addition to backing them up on my iMac.
Interested in this. Can you tell me how many images on what size DVD please?
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,470
Reaction score
756
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
Hi Sue:

You can easily fit hundreds and maybe even a thousand photos on a single 4.7GB DVD-R. Of course it's best to arrange them in folders according to subject otherwise it can become difficult to find something you may be looking for.

You probably already know this... but it's best NOT to use rewritable DVDs.

Some folks have said that DVDs and CDs deteriorate over time but I have not noticed that even with media that is 10 years or more old.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Followed all the advice here, wiped the phone, etc. and the problem disappeared, but it's back again. What the heck? Could it be a connection with the ear bud jack? I'm using the ones that came with the phone.
 
Joined
May 21, 2012
Messages
7,839
Reaction score
141
Points
63
Location
13th state, U.S.A.
Your Mac's Specs
iPhone 11 iOS 13, 12.9" iPad Pro 1 iPadOS 13, Late 2014 Mac Mini macOS 10.15
It could be, sometimes the connections become jammed.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Joined
May 21, 2012
Messages
7,839
Reaction score
141
Points
63
Location
13th state, U.S.A.
Your Mac's Specs
iPhone 11 iOS 13, 12.9" iPad Pro 1 iPadOS 13, Late 2014 Mac Mini macOS 10.15
Not if the connection inside the port is jammed. But, you may be able to clear whatever is jamming it?
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Not if the connection inside the port is jammed. But, you may be able to clear whatever is jamming it?
I don't see anything in the port, but I live in a sea of cat hair. Any suggestions as to how to clear it? Tried blowing in it; afraid to use hairdryer on it
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,470
Reaction score
756
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
Followed all the advice here, wiped the phone, etc. and the problem disappeared, but it's back again. What the heck? Could it be a connection with the ear bud jack? I'm using the ones that came with the phone.
How about when you don't use your ear buds? Does the same problem occur?

By the way, the ear buds that came with your 8 have the same connector as the charging cable. So, I don't see how the connector or connection could be defective somehow.

I'm going to try to do some more searching about your problem to see if others have the same thing happening.

Are you by chance using a protective covering on your phone's screen? There have been reports of certain protective screens causing problems with touch and tap.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
How about when you don't use your ear buds? Does the same problem occur?

By the way, the ear buds that came with your 8 have the same connector as the charging cable. So, I don't see how the connector or connection could be defective somehow.

I'm going to try to do some more searching about your problem to see if others have the same thing happening.

Are you by chance using a protective covering on your phone's screen? There have been reports of certain protective screens causing problems with touch and tap.
Thanks chscag. I don't use a covering on the screen. Charger works fine. And yes, same thing happens - default to speaker permanently - even without earphones.
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,470
Reaction score
756
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
Okay... this is what I found. Check the setting that's indicated here:

"Open the “Settings” app on the iPhone and head to “General”, then go to “Accessibility” Look under the Interaction settings for “Call Audio Routing” and tap on it.
Change the setting from “Automatic” (the default) to “Speaker” to make speakerphone the default for all calls made to and from the iPhone."

Make sure you haven't selected the above. If you have, the speakerphone will always be on.

Let me know.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Okay... this is what I found. Check the setting that's indicated here:

"Open the “Settings” app on the iPhone and head to “General”, then go to “Accessibility” Look under the Interaction settings for “Call Audio Routing” and tap on it.
Change the setting from “Automatic” (the default) to “Speaker” to make speakerphone the default for all calls made to and from the iPhone."

Make sure you haven't selected the above. If you have, the speakerphone will always be on.

Let me know.
Under Audio Routing I have only 2 options: "Call Audio" & "Media Audio". Because I have hearing aids, and I don't stream from my phone, the only choice I have under those are "never hearing devices" or "always hearing devices" or "automatic". I don't want my phone ringing in my ear, so I have it set at "never". I have no other options. Could this be forcing the use of Speaker?
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,470
Reaction score
756
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
Yes, it's possible that's driving your speakerphone on rather than the default off. Try varying the settings to see if that works.

By the way, you never mentioned to us that you wear hearing aids. That definitely makes a difference because iOS software handles that in a different way.

Also it appears that the settings in iOS 13.4 have changed somewhat but it looks like you found the correct "Audio Routing" setting.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Yes, it's possible that's driving your speakerphone on rather than the default off. Try varying the settings to see if that works.

By the way, you never mentioned to us that you wear hearing aids. That definitely makes a difference because iOS software handles that in a different way.

Also it appears that the settings in iOS 13.4 have changed somewhat but it looks like you found the correct "Audio Routing" setting.

Just got my extra ears! Some jerk threw a firecracker under my feet when I was in college, and there was no available tech until now. Turned off the "Hearing Aid compatibility" functionality, and hoping that will take care of it. I may have to remember to check on that often. Will let you know how it works, because I'm sure others with hearing issues will have the same problem, although it seems most people stream directly into their ears.

Thank you so much chscag! I can't add to your rep; I tried, but :app
 
Top