• Welcome to the new Mac-Forums. See News and Community Announcements for more details.

iMessages a mess

Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
iMessage is not threading properly on 12.4.1. I send a text, and the reply comes back without my original text. iMessage also only recognizes some iPhones, even though I have checked "iPhone" in Contacts. Now on iPhone 8 - brand new, and still the same issue. Thoughts please?
 

Slydude

Well-known member
Staff member
Moderator
Joined
Nov 15, 2009
Messages
15,145
Reaction score
319
Points
83
Location
North Louisiana, USA
Your Mac's Specs
2.8 GHz 2008 MacBook Pro 10.11, 8 GB mem, iPhone XS, 2015 iMac 16 GB 10.15.5 beta
There must be something out of whack in the settings as opposed to a general issue with 12.4.1. I haven't experienced either problem so far. Even on the IOS 13 beta.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
There must be something out of whack in the settings as opposed to a general issue with 12.4.1. I haven't experienced either problem so far. Even on the IOS 13 beta.
I can't figure out what is wrong in settings, as we have this problem on my husband's SE, my former 6 (which I just traded in today) and now on my 8. Need to get this back in whack! It started with iOS 12
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,461
Reaction score
755
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
I can't figure out what is wrong in settings, as we have this problem on my husband's SE, my former 6 (which I just traded in today) and now on my 8. Need to get this back in whack! It started with iOS 12
I've seen this problem before. Try signing out of iCloud on both your 8 and your husband's SE. Then sign back in on both.

Also check System Preferences, iCloud on your Mac to make sure you're syncing properly.

If all that doesn't work, sign into iCloud on your Mac with your Apple ID and Password and then check your iMessages to see how they look and if they're threading properly.

Another question for you.... Do you and your husband use the same Apple ID and Password? Or do you have separate accounts?
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Thanks chscag. It didn't work on either phone, even after signing in and out of iCloud.

iMessages on my Air do thread properly.

Spouse and I have different Apple IDs and passwords.
 
Last edited:
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Ok - I've got this down to one problem; my iPhone refuses to recognize my huband's iPhone - treats it like an Android and only uses SMS. I've deleted him as a contact and reset all parameters, signed in and out of iCloud on both phones, signed in and out of iMessages on both phones. His iPhone recognizes my phone as an iPhone, but my iPhone 8 won't recognize his. I've backed up and reset my iPhone, and it didn't change. Any ideas as to what is happening here? Nearest Apple Store is 1 1/2 hours away, and I'm trying to avoid that, if possible. Appreciate any help
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,461
Reaction score
755
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
Are you both running the latest version of iOS? (13.1.1) Don't know if that will help but you might try upgrading if you're on an older version of iOS.
 

Rod


Joined
Jun 12, 2011
Messages
5,938
Reaction score
179
Points
63
Location
Melbourne, Australia and Ubud, Bali, Indonesia
Your Mac's Specs
2015 MacBook Pro Retina 13" macOSX 10.15.1
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Are you both running the latest version of iOS? (13.1.1) Don't know if that will help but you might try upgrading if you're on an older version of iOS.
Both phones on 13.1.1
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Yes, I wiped the old iPhone 6 at the Apple store when I got the new iPhone. Thank you for info regarding managing devices - just deleted old iPhone.
 
Joined
Jan 1, 2009
Messages
8,038
Reaction score
151
Points
63
Location
Winchester, VA
Your Mac's Specs
MBP 15" Mid 2015, iPhone 11 Pro, an iMac, plus ATVs, AWatch, MacMini
Go into Contacts, find your husband's entry. Edit it and change his phone number from whatever it is now to "iPhone." Believe it or not, that is what I had to do to solve exactly the same issue with my new iPhone and her new iPhone. I have no idea if that was a change, or what, but despite restoring to the two new phones and following the steps from Apple precisely, her number got entered into my contacts as "Mobile" and not "iPhone" and that forced SMS instead of Messages. Very strange.

EDIT: You might also need to change your setting in his phone.

EDIT EDIT: You might also look at Settings/Messages/Send&Receive and check that the address includes telephone numbers for your account. That got mucked up, too.
 
Joined
May 21, 2012
Messages
7,833
Reaction score
141
Points
63
Location
13th state, U.S.A.
Your Mac's Specs
iPhone 11 iOS 13, 12.9" iPad Pro 1 iPadOS 13, Late 2014 Mac Mini macOS 10.15
Can you go to your carriers store? They should have a fix for that, or even call them? More than likely, they’ve dealt with this issue before.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Go into Contacts, find your husband's entry. Edit it and change his phone number from whatever it is now to "iPhone." Believe it or not, that is what I had to do to solve exactly the same issue with my new iPhone and her new iPhone. I have no idea if that was a change, or what, but despite restoring to the two new phones and following the steps from Apple precisely, her number got entered into my contacts as "Mobile" and not "iPhone" and that forced SMS instead of Messages. Very strange.

EDIT: You might also need to change your setting in his phone.

EDIT EDIT: You might also look at Settings/Messages/Send&Receive and check that the address includes telephone numbers for your account. That got mucked up, too.
That's the weird thing; his phone is listed as iPhone, and I've even changed it to "mobile" "home" "work" etc and back to iPhone, and my phone is stubbornly refusing to acknowledge his phone as iPhone.

- - - Updated - - -

Can you go to your carriers store? They should have a fix for that, or even call them? More than likely, they’ve dealt with this issue before.
That's a great idea - thanks! Will let you know if they can fix it. Since everyone has been so helpful here, and I've tried all the suggestions, it must be a problem on their end. I hope. Will let you know!
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
Just want to thank everyone here for trying to help me out. Took problem to Genius Bar, and they couldn't fix it either. They did replace the iPhone 8, which had multiple problems, and I have a call coming up from Apple to try and solve this. They did explain that iMessage issues can not be a carrier issue, as iMessage bypasses your carrier; I didn't realize that.
 
Joined
Nov 12, 2011
Messages
362
Reaction score
2
Points
18
Your Mac's Specs
MBA mid-2013 1.3GHz i5, 4GB 1600MHz DDR3, Intel HD Graphics 5000 1536MB; iPhone 8; iPad Air2, 64GB
SOLUTION!!!! You must have an area code in front of every iPhone number in your contacts! I didn't put an area code in contacts for those in my area code, and that was the problem. At least it's a very simple solution!
Again, thank you all for your help!:phew
 
Joined
Oct 16, 2010
Messages
13,227
Reaction score
210
Points
63
Location
Brentwood Bay, BC, Canada
SOLUTION!!!! You must have an area code in front of every iPhone number in your contacts! I didn't put an area code in contacts for those in my area code, and that was the problem. At least it's a very simple solution!
Again, thank you all for your help!:phew


Good sleuthing...!!!

But I would suggest that if you don't have to normally add the area code when you use your normal phone to call the party, I would suggest that is some pretty sloppy programming to not automatically exempt all "local" numbers.

Or there should be some indication that the number is not complete or at least for what was expected. Sloppy, and it should "Just Work"!!!


- Patrick
======
 
Joined
Jan 1, 2009
Messages
8,038
Reaction score
151
Points
63
Location
Winchester, VA
Your Mac's Specs
MBP 15" Mid 2015, iPhone 11 Pro, an iMac, plus ATVs, AWatch, MacMini
Patrick, I don't know about Canada, but here in the US the area code is increasingly required to make any calls, so it's natural for Apple to expect it in contacts. In my area, Winchester, Virginia, you have to dial all 10 digits, even for local calls. And if you don't, you get an error tone and a message to tell you to include the area code. So, Apple *is* including "local" calls with the 10 digit requirement.

Frankly, I think it would have been sloppy programming to leave area code out of the requirement.
 

chscag

Well-known member
Staff member
Admin
Joined
Jan 23, 2008
Messages
60,461
Reaction score
755
Points
113
Location
Keller, Texas
Your Mac's Specs
2017 27" iMac, 10.5" iPad Pro, iPhone 7+, iPhone 8, iPhone 11, Numerous iPods, Catalina
It's the same in Canada Jake. Their phone system is tied to ours and has been for years. Western Electric owned Northern Electric before the big breakup of Ma Bell back in the 80s.
 
Joined
Jan 1, 2009
Messages
8,038
Reaction score
151
Points
63
Location
Winchester, VA
Your Mac's Specs
MBP 15" Mid 2015, iPhone 11 Pro, an iMac, plus ATVs, AWatch, MacMini
What makes it even more interesting, Charlie, is that my area code is 540, and some folks in that area are "local" calls, but there are others that I have to dial a 1 first. Not on my mobile phone, but on the landline. So I've taken to dining 1 all the time, as it works for local numbers as well as the "local" that require it. But I plan to ditch the landline in a couple of months and go all mobile, so that's all going to go away.
 
Top